Ubuntu Mate shows black screen on Monitor, but not TV

I flashed the Ubuntu Mate ARM64 20.04.1 Beta 2 to my RPi 3B+'s SD Card, but when I turn it on, the monitor turns on (it seems to be receiving a signal), but it just shows a black screen.
I then tried it with my TV, and it was working.
I use a HDMI-to-DVI adapter with my monitor, but I've tried it by running Raspbian Buster Lite, and it works.
I don't know how to fix it, as Raspbian is working fine.

I had something like that happen to me as well, only the small screen TV (24") I use as a monitor didn't work, but the large format TV (50") did. The fix was a change to usercfg.txt.

Start by appending hdmi_safe=1 and see if that brings things to life in an 80×24 text format. That's what we want to see. If that works, you have some homework to do. If it doesn't, it'll be something else, as the Pi 4 is very picky in some circumstances (not running raspbian may qualify as a trigger for the behavior).

If hdmi_safe=1 worked, research all of the resolutions the display supports. Pick the highest one you are comfortable with. Next, look at the resolutions table and locate the closest mode value.

Replace the hdmi_safe statement with the closest hdmi_group/mode and try again (I'd spell them out, but I don't have access to the machine I did this on right now). With luck you'll be in business.

1 Like

setting the hdmi_safe yields the same result unfortunately.

I've seen it reported that some monitors/tvs don't like the settings proviced by hdmi_safe=1.
Best thought is to fire up Raspbian and get some valid settings from tvservice -s
raspberrypi.org is the place to find the list of settings