Unresponsive firewall [Solved]

I've tried to find an easy install of mate desktop for RPi 3 users after pointing out to them that
the software ,MSHV, I compile the binaries for linux can never work in the debian based
OS raspbian. It works fine in Ubuntu
The ubuntu method of install the server then the desktop is a bit complex for novices and does not always start the desktop
so I've recommended the beta version of the mate desktop
ubuntu20 is a bit to resource heavy for a RPI3B, hence the use of 18.04

on both the 32 and 64 bit versions incoming ports are closed.
even when UFW is set to accept all incoming and a rule is written to ufw conf
to accept incoming on port22.
Its NOT a network problem as if I install the ubuntu-server no problem with connecting to it on port 22, its just on the desktop version.
What magic incantations are required to allow incoming connections, its as if there are two firewalls .
I'd copy and paste the config , if I could get in to the wee beastie remotely

Reading through some other posts, I came across a comment about the openssh-server

Problem resolved
sudo apt purge openssh-server && sudo apt install openssh-server

However, that package does produce a considerably slower RPI3B than
installing ubuntu-server, and using tasksel to install mate desktop
Maybe why it never passed the beta stage