Update today disables Calibre entirely

After todays system update Calabre would not start. Reinstalled app - same fault.

Reloaded Clonezilla image from before update. Calabre then worked normally. Redid update and Calabre again failed.

Reloaded my working image so I can work. I have a Clonezilla image of the faulty disk. [just system]

Please see this bug report and the included developer discussion. Feel free to add to the report.

@franksmcb, the version in Groovy (4.99.12+dfsg+really4.23.0-1) is working fine. I will update the observation in the bug report. Can it be backported to Focal without waiting for 5.2 release?

Not related but what is 'SRU' that Lukasz was referring to?

@xaire,
As you may have seen the bug report comments, it will take some time for the issue to be resolved. If it is urgently required by you, you can install 'flatpak' version of calibre (which is at version 5.2.0). Open a terminal and type following ('c' is capitalized)

flatpak install Calibre

If 'flatpak' support is not enabled on your system, ref to https://flatpak.org/setup/Ubuntu/ for instructions to enable flatpak support.

2 Likes

That SRU business always vexes me too. Please see -

https://wiki.ubuntu.com/StableReleaseUpdates

2 Likes

Thank you @mdooley. SRU=Stable Release Updates. I will read the linked wiki.

1 Like

Here's another link that might help you see a lot more -

2 Likes

@franksmcb, your the bug report says,

Remember, this bug report is a duplicate of bug #1898904.. Comment here only if you think the duplicate status is wrong.

So, I sent email to ubuntu-devel list(currently waiting for mod approval). In case my msg doesn't get through, kindly pass info in devel list. TIA.

There is a patch available upstream that will resolve this, see bug report: https://bugs.launchpad.net/ubuntu/+source/calibre/+bug/1898904 posts #9 and #10. For brevity I am including the instructions.

You can find the shell script here: patch.sh

Instructions:

  1. Download file patch.sh
  2. Open terminal, default keyboard shortcut is: CTRL+ALT+T
  3. Set execution permissions: chmod 700 patch.sh
  4. Execute commands: ./patch.sh
  5. Then you can delete patch.sh file: rm patch.sh

Both Norbert and myself have tested the patch and it does resolve the issue.

2 Likes