Upgraded to 20.04 and the Menu keeps closing

I successfully upgraded to 20.04LTS from 18.04 and I'm having one major problem.

When I click on the Menu in the panel (or use the "Windows" key on my keyboard, it only stays open for a second or so before closing. It should stay open until I click something.

What's wrong and how do I fix this?

Hi dalesd,

run the following terminal command (Ctrl + Alt + t).

sudo apt-get update && sudo apt-get dist-upgrade

Restart after and see if the menu opens.

See the update guide for fixing broken packages etc. :grinning:

1 Like

I followed the wolfman advice above. The following packages will be upgraded:
build-essential gnome-control-center gnome-control-center-data
gnome-control-center-faces python3-distupgrade ubuntu-release-upgrader-core
was the result -- done. I have never had an issue with the Menu on 20.04.1 as a regular user; however, the menu behaves as in the question when I login as root (I have established that account with GUI as well as plain terminal screen). The default Ubuntu window GUI system does work. Any fixes? Does root need a special configuration such as was needed to both allow login (not just sudo) and MATE GUI as root?

Hi YKar,

the menu should behave like it does as a normal user but I have to ask why you want to log in as root?, that is not a good idea and you shouldn't do it!. :smiley:

1 Like

Hi Wolfman,

I could give you my experience and qualifications, including professional expertise in "unix" kernel internals and having taught sysadmin to computer science students (not IT persons), but that is not the matter of interest. In practical terms, it is that I do not use Thunderbird, Firefox, or Seamonkey from any distro -- I use the production current release from the original provider for the environment and platform I need. These applications under Help -> About show an update box when an update (from the provider, not repackaged/rebuild by a distro) is available. As an ordinary user, this "box" no longer prompts for the admin password, but refuses to update. However, if I login as root to a GUI window session (e.g., using MATE), the update box becomes active, and the update is performed for all accounts. Clean and simple. If the system would allow provider versions (as I use) to update from a user account with authentication, I would do that. Does this help?

I can confirm that if we log into GUI as root, the menu keeps closing making it impossible to launch applications. However, this is only for the default menu, called 'Brisk Menu'. No issues with other menus available. You could either add another menu (Classic Menu, Advance MATE Menu) using 'Add to Panel' option (right click on panel) OR easier way, by changing layout that does not use 'Brisk Menu', e.g., 'Traditional' or 'Redmond'.

I just did a Switch User from MATE as myself and logged-in as root, and selected Mate from the list before entering my root password. I then installed Advance MATE Menu to the top panel. Advance MATE menu does work. Three curious things: (1) after installing Advance MATE menu, the default (Brisk?) menu now works as well, and the default menu will not allow me to remove it from the panel; (2) using either MATE menu, I cannot pin an application to the desktop although reading the contents of ~root/Desktop/firefox.desktop, everything "should" work; (3) when I went to logout from root using the MATE pulldown menu on my right-hand side, there was a report that CAJA was not letting the logout proceed, although eventually it did log me out and I am now a regular user (myself) submitting this reply. Again, I hasten to point out that MATE under SL7 (an EL clone and distro) acted "normally", not like what I am describing.

1 Like

Hi Ykar,

have you tried changing the desktop layout, eg: Traditional and see if that has any effect that might allow you to add/remove icons to/from the desktop or panel?. :thinking:

Just did as you suggested: traditional blue. No effect. I did note that when I attempted to logout from root (to return to the user login from which this note is being composed), Caja was still running and I had to "logout anyway" -- making me suspect that something else is wrong. Are there other configuration changes you might suggest? The current new and current Gnome classic flashback (not MATE) both work as expected, and current Gnome classic flashback is usable, although I would prefer MATE as it is not an afterthought on the part of the Gnome developers who have enough pushback from users (e.g., as myself, switched to MATE) and evidently want to keep the Gnome user base.

Strange. In my case it is opposite. Brisk menu still continues to misbehave but I was able to remove it from the panel.

I can confirm this. The desktop file shows in root's Desktop folder (can be seen even from file manager) but no icon is shown in the desktop. Also, there is no right-click menu in the desktop for root user.

I could not reproduce this even after several switch user, logout attempts. Sometimes it took long time to logout (about 27s) but never saw Caja errors.

Are there particular configuration files and/or lists of actually installed packages (including kernel, etc.) that you would need to see from my system in order to determine why the two erstwhile "identical" systems in part behave differently. I assume that you are testing on Ubuntu 20.04.1 LTS with "current" production packages. I assume you also would need the list of all packages installed on my system in the event that there are unexpected package interactions. Is it possible that a package installed/updated after MATE but that I need for some other application environment "changed" a MATE needed configuration file that would cause the differences we observe? Note that I have installed Gnome throwback classic (a MATE-like version of the current Gnome production package) so that I can have something akin to what I prefer as root. This does not seem to have affected my end-user account.

Apart from not logging in as root, I don't have anything else for you, sorry!. :worried:

I actually tested this issue on Debian (buster), Ubuntu MATE 20.04.1, Ubuntu 21.04 (devel) and LinuxMint 20. Following are my observations.

  1. Debian -
    • No issues with Brisk menu (doesn't collapse under root login). Version - 0.5.0-9
    • No desktop icons on desktop (no right-click option in desktop) although the .desktop files show under /root/Desktop. MATE release - 1.20.4
  2. Ubuntu MATE 20.04.1 and LinuxMint 20 -
    • Brisk menu collapses for root user. Version - 0.6.0-1ubuntu1
    • No desktop icons on desktop (no right-click option in desktop) although the .desktop files show under /root/Desktop. MATE release - 1.24.0
  3. Ubuntu 21.04 -
    • Brisk menu collapses for root user. Version - 0.6.2-1
    • No desktop icons on desktop (no right-click option in desktop) although the .desktop files show under /root/Desktop. MATE release - 1.24.1

So, the 'desktop application shortcut not visible' issue is common and possibly related to root user's profile for Caja. It may be specifically disabled (which I do not know).

The brisk-menu issue seems Ubuntu specific as it is behaving fine in Debian (older version). I couldn't test on 18.04, which may also have older version of the package. If so, I will raise a bug report for brisk menu.

1 Like

I found this issue (#871) on MATE's GitHub, discussing caja desktop behavior under root login. The solution is to have a local caja.desktop file for root user with --force-desktop option. It also states why desktop icons are disabled for root user. It is a good read.

As root (or sudo) do,
cp /usr/share/applications/caja.desktop /root/.local/share/applications/
and then append the Exec line as,
Exec=/usr/bin/caja --force-desktop .
Re-login and you will have desktop icons and application shortcuts.

A snapshot below from root login.

I must add, I haven't worked in this set up for long to know if this would create other problems.


I just did the above cp, edit of the .local version of caja.desktop , and then did a GUI switch user to root . Not only did this solve the desktop problem, it also solved the "brisk" MATE menu (standard current MATE upper panel user left end Menu drop-down) -- these no longer keep closing. As with other applications/environments, the Ubuntu implementation is designed to limit the functionality of root per se (not sudo that has other limitations); however, there are configuration file changes (as explained above for this case) to "restore" operational functionality. I just pinned Thunderbird to the root GUI desktop -- this allows me to switch user to root, invoke developer production Thunderbird without using the menu (not distro Thunderbird), and update (in place, not a full download of the tar.gz file) Thunderbird to production current. I then logout root and return to my enduser desktop (and account), with Thunderbird updated to developer production current.

1 Like

I was having this problem with Ubuntu Mate 20.04.

To fix it I only edited:


and changed:



Exec=/usr/bin/caja --force-desktop

Log out and back in and now it all works.

thanks everyone.