Upon the endless quests for the 'newest' stuff

This 1st part will seem unrelated to what is discussed here, but stick around as I assure you that it IS related in the manner I aim at here.

Recently we were forced by the need for high priced repairs to trade our '06 car 'up' against the cost of an '11 model ready to just drive away as it sat.
Sure, the newer car is very nice in certain ways - while also having added tech oriented stuff that is simply nonsensical (IMO).
The fully automatic rear view mirror with the flickering & ever changing compass display ??
Re-dik-oh-rous.
Doing away with the engine temp gauge in favour of blue/red idiot lights ??
Sheer idiocy.
Replacing the typical tailgate lever with an all-electric mechanism ??
Absurd, at BEST. (And no way to open it with a key anymore...meh.)

And worst of all:
Keys that MUST come from the dealer & cost ~$300 EACH for replacement !!
Good grief.

So - relating all that with the journey into 20.04 (which is already 'old news', I know...) :

This stuff only became obvious to me during my efforts to upgrade my partner's PC to 20.04 - and getting desired functions to work for her.

The most absurd one was getting LAN Messenger - which is easy as pie on 18.04.x - but for 20.04 is a total no-go.
Fortunately its 32 bit portable made for that 'other' OS works just fine.

A personal gripe for me is WINE Launcher Creator, which allows one to make .desktop entries for WINE apps in a full & delightfully easy manner.
HAHAHAHAHAHA !!
Joke's on me. No way Jose, not even by donating some body parts in payment - this app totally hits the wall though it is made for specifically Linux.
And why is that you ask=> just because it needs python-qt4.

Yes - I know exactly how to make those entries 100% manually - and they work fine so long as having the funny spring icon is OK - vs. that great app that does the whole thing in a secone WITH adding the nice icon of the user's choosing included.
Presto - done.

Can I get the icons out of the .EXE files easily ??
Sure - by using yet ANOTHER 32 bit windows app.

And the list of things for which there are active Synaptic entries in 18.04.x BUT which do not exist at all under 20.04.x is really too lengthy to remember - but there are just too many like that.

Now...
Adding in what I've seen just recently about the (non-LTS) 21.04 release, I remain truly & totally delighted to be staying with good, old version 18 !!!

I see no reasonable advantage in embracing the notion that 'newer is better', and can see what keeps a great many PC users AWAY from 'upgrading' their beloved XP - and I cannot find any flaws in their thought processes about that EXCEPT that if they switched to a good Linux distro they would have superb browser choices available to them.

That is all that comes to mind for me right now - just my 2.5 cents on this whole idea.
The amount of time spent working at getting good solutions for that PC & OS version was excessive IMO.
Of course I expect many, many folks would consider my 'philosophy' as expressed here to be far below them.
I'm good with that.

1 Like

I understood the idea behind your post.

The reasons behind all these problems is release cycle. Some stuff is now considered end-of-life upstream - for example python2 and Qt4. Here upstream means real upstream, not Debian or Ubuntu repositories. Being EOL'ed all old stuff are almost gone from Debian repositories which are common for both Debian and Ubuntu.

I'm a big fan of Ubuntu MATE 18.04.6 LTS, I still use it on all my daily workstations. I'm writing this post from Ubuntu MATE 18.04.6 LTS. So personally I run about 10 devices with Ubuntu MATE 18.04.6 LTS because I need to have python2-based applications like Zenmap and Fslint, and to have Qt4-based applications in place. So I do not think that we all must to upgrade our systems to the latest supported Ubuntu MATE 20.04 LTS. I'll continue to use 18.04 LTS until release of 22.04 LTS to keep my user experience gap-less.


But please be more specific, drop emotions and provide a list of relevant deb-package names of the needed applications. You can use https://packages.ubuntu.com/ to ease the search. Together we can try to reach solution for your current Ubuntu MATE version.

6 Likes

Sincere thanks for your kind Hearted reply Norbert_X.
I do use that packages site, and when all else fails I also search for the desired app via the DEB's filename.

That 20.04 system is now in place and fulfilling her needs as I covered all the vexations well enough & she really was needful of having it ASAP to get some work offers arriving via email in the way that she knows how to use it best.

The biggest vexation was actually LAN Messenger:
https://lanmessenger.github.io/
Tried to get it for 20.04 as well as BeeBEEP, iptux & others - no go.
What I did get to work for her is the LAN Messenger w32 portable via WINE.

I had already mentioned Wine Launcher Creator as another impossible dream for 20.04, and details of that are shown here:

And here:
http://code.google.com/p/wine-launcher-creator/

I do have another disk mostly set up with 20.04 for my own (eventual...) uses, and my vexations with that began with the opposition to using Geeqie - which it INSISTS upon auto-removing - and a personal all-time favourite that I will not be without - Mooedit:

For myself the easy choice will be to do the needful to get the 18.04 extended support when that time arrives - and in the meantime I'm keeping an open mind towards 20.04 for my own possible future uses.

I do find it amusing that generally, when all else fails with native Linux apps - even after tracking down the most recent applicable DEB file and or chasing around in circles to meet impossible dependencies - it is very often quite easy to find a suitable work around via a w32 app & WINE.

Examples:
There is -NO- Linux app as good as WinRAR, for example, and as I sit here at my main PC the icons for Wordweb, Uptime Scout, ChamClock and nPOPuk are all active in the panel & ready for my uses all the time.

There is also no equivalent of the Mypal browser, which gets used every day by me.

Another pipe dream would be getting MyPhoneExplorer to work correctly & fully via WINE - and it can be installed, opened & does -sort of- work, but NEVER via USB connection & it often corrupts APK files when side-loading via wifi, making that mostly unusable, sadly.
Even its dev refuses to help Linux users despite his claims that it WILL work via WINE.

As I see it, a truly 'smart' PC & OS would arrive ready to run apps from not only its own origins - but also at least legacy windows apps as well as Android apps without using a VM or making any huge amounts of patchwork efforts to achieve those goals.

There was a very attractive Linux distro which arrived with WINE all set up and also AndroVM - but it was sort of a huge mess with plenty of problems, the least of which was pretty much zero support as well as little attention with very few active users:
https://prathamosconnect.blogspot.com/
https://sourceforge.net/projects/getprathamos/files/ADYAH/

Easily shown by trying to visit...
https://prathamos.com
Which has become a dead end though it is still linked on the blogspot page listed above.

When it comes to solving Linux problems I generally do pretty well by searching & following good advice from others when found by those means.

When all else fails and I've run the entire gamut of options - I either choose a different route, or finally ask here and/or at Ubuntu forums.

Sometimes - like when I wanted to use an Android device as a webcam under U/M 18.04 (and did post here about it...) no working solution can be had - so I just move on without wasting any more time or efforts on such a thing.

Let's try to fix problems with each application separately for current Ubuntu MATE 20.04. I tried to prepare a list of the applications mentioned in your posts:

  • LAN Messenger

    It has an issue with old libssl1.0.0 package, but installable with below workaround:

    cd ~/Downloads
    wget -c https://github.com/lanmessenger/lanmessenger/releases/download/v1.2.37/lmc_1.2.37_x86_64_min.deb
    wget -c http://archive.ubuntu.com/ubuntu/pool/main/o/openssl1.0/libssl1.0.0_1.0.2n-1ubuntu5.7_amd64.deb
    
    sudo apt-get install ./libssl1.0.0_1.0.2n-1ubuntu5.7_amd64.deb
    sudo apt-get install libqt5multimedia5
    
    sudo apt-get install ./lmc_1.2.37_x86_64_min.deb
    
  • BeeBEEP

    Is installable from authors deb-file using commands below

    cd ~/Downloads
    wget -c https://sourceforge.net/projects/beebeep/files/Linux/beebeep_5.8.4-1_amd64.deb/download -O beebeep_5.8.4-1_amd64.deb
    sudo apt-get install ./beebeep_5.8.4-1_amd64.deb
    

    Also installable as Snap by snap install beebeep .

  • iptux

    Is located in official Ubuntu repositories, so installable by

    sudo apt-get update
    sudo apt-get install iptux
    

    The Snap version is also available to install by snap install iptux.

  • WINE Launcher Creator

    Depends on Qt4, but still maybe installed by using special Qt4 PPA and following commands:

    sudo add-apt-repository ppa:rock-core/qt4
    sudo apt-get update
    
    cd ~/Downloads
    wget -c http://archive.ubuntu.com/ubuntu/pool/universe/q/qt-assistant-compat/libqtassistantclient4_4.6.3-7build1_amd64.deb
    sudo apt-get install ./libqtassistantclient4_4.6.3-7build1_amd64.deb
    
    wget -c http://archive.ubuntu.com/ubuntu/pool/universe/p/python-qt4/python-qt4_4.12.1+dfsg-2_amd64.deb
    sudo apt-get install ./python-qt4_4.12.1+dfsg-2_amd64.deb
    
    wget https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/wine-launcher-creator/wine-launcher-creator_1.0.8-1_all.deb
    sudo apt-get install ./wine-launcher-creator_1.0.8-1_all.deb
    
  • Geeqie

    Is located in official Ubuntu repositories, so installable by

    sudo apt-get update
    sudo apt-get install geeqie
    

    The Flatpak version is also available, but it is equal to focal's version.

  • Mooedit

    Here interesting moment exists, the deb-package is named medit instead of expected mooedit. Still installable using deb-package from 18.04 LTS with commands below:

    cd ~/Downloads
    wget -c http://archive.ubuntu.com/ubuntu/pool/universe/m/medit/medit_1.2.0-3_amd64.deb
    sudo apt-get install ./medit_1.2.0-3_amd64.deb
    

    Manual compilation of latest 1.2.92 is possible, see my dedicated post on AskUbuntu.

  • Windows software category, using WINE and so on

    This category is really broad, can't be covered in short post.

    To ease installation of Windows software on Ubuntu one can use PlayOnLinux - a set of well-tested recipes. It is available in official Ubuntu repositories and installable as simple as sudo apt-get update && sudo apt-get install playonlinux.

    All applications from your list - WinRAR, Wordweb, Uptime Scout, ChamClock, nPOPuk, Mypal browser, MyPhoneExplorer do not exist in PlayOnLinux catalogue.

    But some of them are listed in Wine AppDB with high levels of support: WinRAR (platinum), Wordweb (silver), MyPhoneExplorer (gold). So there are chances to use them with Wine.

    Wine theme is very wide, there is a nice related article named Wine on ArchWiki.

    If understand your problem with icon extraction from exe-files correctly, then you have to install single special package named exe-thumbnailer by sudo apt-get install exe-thumbnailer, it will show the icons for EXE files. Then restart Caja by caja -q.

  • Running Android applications on Ubuntu

    I know that other solutions exist but for my personal use I do the following.
    I install full Android Studio IDE using ubuntu-make by

    sudo add-apt-repository ppa:lyzardking/ubuntu-make
    sudo apt-get update
    sudo apt-get install ubuntu-make
    
    umake android
    

    and then create Android Virtual Devices (AVD) with needed Android versions and device class (Phone, Tablet or TV) and launch them. Go to Applications → Programming → Android Studio, click Configure, select AVD Manager to proceed - use Create Virtual Device for first time or click on ► to launch existing AVD.

  • Android device as a webcam

    On my daily Ubuntu 18.04 LTS system I use the well known DroidCam software to access Android phone as USB web-camera.

    For Wi-Fi only video capture you can install some application on Android phone - for example IP Webcam and then connect OBS Studio (snap version from Wimpy is great!) to it.


Tools used to get above problems fixed:

  1. Ubuntu Packages Search
  2. App Outlet
  3. Wine AppDB
2 Likes

Norbert_X, you are AMAZING & Amazingly Generous.

Sincerest Thanks for all your time & efforts.
(I wish there could be something I could do for you in return for your wonderful generosity.)

Referring to your wonderful reply=>

WINE Launcher Creator - wow - I tried at least some of your solution, but still failed, I shall try again as that app is a real gem IMO !!

LAN Messenger - I will now replace her w32 version with this method, thank you !!

BeeBeep & iptux - I've already forgotten what the exact problems were with those, sorry !! (And thanks for the solutions.)

Geeqie, as I said, kept autoremoving itself when I used apt & I do have the DEB file for it.

Yes - Mooedit is named medit also, and I had grabbed the 1.2.0-2 versioned DEB for my 18.04 - thanks for that info too !!

As to WINE, I have & use V6 with great happiness as well as POL, etc.

Those apps I mentioned -do- function wonderfully well under WINE - that is EXCEPT for MyPhoneExplorer, which is a waste of time IMO, so I use it as & when it is needed by booting my 'play' box into XP.

At some point I will re-try it using the info that you provided, here:

I have little hope of it connecting as it is meant to via USB though because I've found before that gaining that access under Linux requires a bunch of other complex actions vs. that it just connects to phones via USB under XP effortlessly & without corrupting sideloading of APKs as it does when used via wifi under 18.04 for me.

For Droidcam & Iriunwebcam the trouble I had under 18.04 was with v4l2loopback specifically - and I will try it again as my kernel version is now different than it was when this was last attempted.

Here we are now:

localization failed
You may want to run:
sudo modprobe v4l2loopback exclusive_caps=1

And when I do that:

modprobe: ERROR: could not insert 'v4l2loopback': Bad address

Which is about the same as was happening previously IIRC.

I have made careful notes of all you've so generously given here, thank you.

I have seen Releases · AppOutlet/AppOutlet · GitHub before, and will grab the APPIMAGE of it to try on my own 20.04 installation.

As to snaps & flatpaks:
I vastly prefer using APPIMAGE files over getting those others at all & generally try to locate an APPIMAGE file 1st, then test it to see if it functions correctly if I've been stumped by a direct effort via APT or DEB.

Once again:
Immense thanks for your time & efforts here !!

1 Like

Here is a 20.04 problem which may be beyond fixing...:
Systemback, my favourite lifesaving app - can be installed from 1 or 2 of the supposedly 'fixed' sources - and does seem to make its SBLIVE file, BUT=>
In testing it for doing a restore onto a blank drive (same h/w) it cannot use its own file & fails.
This is when using a devoted bootable USB drive.

A working method or version of Systemback for 20.04+ will be a huge miracle as it has always been the very best total backup utility IMO.

1 Like

No equivalent? Have you tried the Pale Moon browser which it's based upon? (linux.palemoon.org)

Sure, personally I don't like Pale Moon -- I used to use it myself but things have just gotten terrible. Now the team doesn't even disclose source code! (Yes, theoretically you can still ask for the code, and they're obligated to serve it up promptly. But will they actually do that? I kind of doubt it, given how much they fear the Mypal people et al.)

I see your point, but thought I'd remind you that the original Pale Moon is an alternative, especially if you don't mind seemingly insane contributors working on the software you trust to handle your online banking details and so on. :roll_eyes:

OK, I just realized myself why you don't consider that an alternative. Sorry to waste your time.

1 Like

Hello Gordon & Thanks for making your reply !!

I do actually have the Linux version of Palemoon despite its funkiness(ES) & it does get used - but not very much.

By way of contrast, Mypal (w32) gets used EVERY day, usually in an early & a late session, whilst Basilisk (Linux) stays open all during my waking hours.

Before this methodology, I used K-Meleon (w32) for my light & quick browser, but keeping up with that s/w became a PITA, so I switched.

Mypal has pretty severe limitations in the way I use it too - and that is by my preferences.
Notestruck & Tab Mix Plus are important to me, and if/when I browse a YT page it is just to check it out 1st as it cannot play any videos.

This all allows me to zip through a whole bunch of pages as quickly as I like, make notes, and not get into any serendipity searching.

And...
Should I wish to view a video that I've noted, I quickly open the APPIMAGE for Librewolf - which does that the lightest & best of any tool I've yet found.

As I write this reply - I have my usual 2 (very customized) Basilisk windows open with several tabs each as well as Mypal - and resource usage remains quite pleasantly low.

A XUL-based web-browser demonstrating the Unified XUL Platform (UXP).
This browser is a close twin to pre-Servo Firefox in how it operates.
( https://www.basilisk-browser.org/ )

And I use this:

Classic Add-ons Archive

For all the goodies I require including the same ones I use for Mypal.

Yes, they are both descendants of Palemoon one way or the other - but better IMO.

3 Likes