USB drives are mounted read-only

USB devices do not allow writes to them because they are mounted read-only in Ubuntu MATE. I can still write with administrator privileges (I write .iso images with Disks utility).

Using Caja, I copy files from the SSD and place them in a USB device (tried 4 devices), but then it fails with the message “(…) Mounted as read-only.” Sometimes the “paste” option is simply grayed out.

Have you tried?

gksudo caja

Or maybe you would prefer changing ownership.

Could be this bug

It’s probably that bug. I will try that gksudo caja workaround later and come back to share the result. Thanks.

EDIT: No, it does not solve anything. It’s probably the bug.

@cyber-doug Update to the 4.7.2 kernel and you are good to go! @anon42388993 it’s a kernel problem!! Updating the kernel to 4.7.2 will fix it!

Could be, could be. I have Solus installed and it has kernel 4.7. No issues there. Where did you find that information?

I did have the same problem like you. and that was the single fix that i found to work. 4.7.0 work, 4.7.1 do not work(have the same problem) ,4.7.2 works

Considering The Ubuntu 4.4 has the issue, 4.7.0 supposedly does not, 4.7.1 supposedly does, but 4.7.2 not, I kinda doubt it’s really a kernel issue. Unless someone points me to some mention of it in the Linux kernel dev discussions / commits, at least…

or you can search yourself. i did try to help you. if you whant more search.
P.S this bug it’s on all ubuntu base os’s (ubuntu unity, ubuntu mate, linux mint, budgie-remix os … and yes i did try all of them)

And yea this is a 3 year bug that apear and disappear …

Sorry, I didn’t mean to offend anyone. And I was not able to find any other mention of this having anything to do with the kernel (only in the context of the entire filesystem going read-only instead of merely the filemanager (caja/nautilus/etc.) claiming it to be read-only).

Edit: btw. someone posted a possible workaround on the Cinnamon bugtracker :
Change #user_allow_other to user_allow_other in /etc/fuse.conf, then relogin.