Vchiq instance fix


#1

Hello community!

I’ve made a fix for the failed to open vchiq instance :tada:
Here’s the instructions, just do what it tells you to do :stuck_out_tongue_winking_eye:


Systemd sevice unit (Step 1)

Save this file in: /etc/systemd/system

Name:permission.service

[Unit]
Description=Allow vchiq to be executed

[Service]
ExecStart=/usr/local/bin/permission.sh

[Install]
WantedBy=default.target

Startup shell script (Step 2)
Save this file in: /usr/local/bin

Name: permission.sh

#!bin/bash
cd /dev
sudo chmod 777 vchiq

Configure and Install (Step 3)

Go to the terminal and type the following:

sudo chmod 777 /usr/local/bin/permission.sh

sudo chmod 777 /etc/systemd/system/permission.service

sudo systemctl daemon-reload

cd /etc/systemd/system

sudo systemctl enable permission.service

sudo systemctl start permission.service


Hopefully this has helped you if you have this problem :blush:
Goodbye for now. :wave: