Video stutters on playback

Very happy with mate 16.04 beta 2 but problem with video driver when using VLC I have Nvidea fx380 using the generic XorgX server driver which of the available nvidea driver is best. the videos stutter on play back


When you say stutter, are you seeing random pauses, or tearing artefacts due to video sync?

As to which NVIDIA driver is best, I would recommend the latest proprietary NVIDIA driver available for your card (found in Additional Drivers). If you encounter any issues, try an older driver.

After driver install, using MATE Tweak try switching to Compiz or Compton to fix screen tearing. Video playback (also web-page scrolling) should then appear smoother.

After performing the above, If still seeing stuttering, consider:

A) Is your CPU powerful enough to handle the video content, does your system have enough RAM to prevent swap partition usage?

B) A newer HDMI cable may be required (recommend at least version 1.4 (for UHD, version 2.0 is required))


See also:

thanks will give it a go tonight- very much a learner driver

1 Like

Thanks to your self and wolfman - applied the following:-

Upgraded the following files - gcc-6-base/libgcc1/libglib2.0.0/libsystemd0/libudenev1 then tried several tweaks and settled on marko(no compositor). My card is nvidea FX 380 so settled for 340.96 Propriety tested driver already in updates file and reboot and all is well. Hope this experience might be of use to someone else.

One other query could not find file libglib2.0-data ?? this came up as a system prompt to upgrade Anthra

Great to hear your problem is fixed!

Would still recommend comparing Compiz (or Compton) with No compositor, once you see the difference (no screen tearing) it’s hard to go back. :slight_smile:

Sorry not heard of Anthra (web search returned no useful information), so unable to offer any help.

How embarrassing, completely missed that Anthra is your name, sorry! :blush:

This might be down to how you have your software sources set?:

a system prompt to upgrade Anthra

If you try and upgrade yourself, you might have a problem!. :smiley:

Thanks working well now

Thanks treading lightly at moment

1 Like

Please mark as solved (put a tick in best answer box at the bottom of the post) so it helps others with the same problem!. :smiley: