VirtualBox Install on 16.04


Brand new to this forum and first install (other than on Win7 in VirtualBox) of Linux. Not sure if I’m posting this in the correct place…(I’m sure someone will correct me).

Trying to install VirtualBox on 16.04 and getting this error:

Kernel driver not installed (rc=-1908)
The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing


as root.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.

I run vboxconfig as root and get this: Stopping VirtualBox services. Building VirtualBox kernel modules. Starting VirtualBox services. Building VirtualBox kernel modules. failed: modprobe vboxdrv failed. Please use ‘dmesg’ to find out why.

There were problems setting up VirtualBox. To re-start the set-up process, run
as root.

Per dmesg:: with error -2
[ 2.001638] nouveau 0000:01:00.0: gr: failed to load fecs_inst

Any suggestions?

When I installed Mate I disabled Secure boot. Should I have done that? Would that make a difference?


Suggestion: install kernel headers for your kernel, VB tries to compile a module. Check you have build-essential and dkms installed sudo apt-get install build-essential dkms linux-headers-$(uname -r)

uname -r

then I run this:
sudo apt-get install build-essential dkms linux-headers-4.4.0-81-generic 4.4.0-81.104(I picked this one from a long list)
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package 4.4.0-81.104
E: Couldn’t find any package by glob ‘4.4.0-81.104’
E: Couldn’t find any package by regex ‘4.4.0-81.104’

Where do I get package 4.4.0-81.104 from ?


4.4.0-81-generic points to 81.104.
dpkg -l | grep linux-image shows that.

You should be able to just sudo apt install linux-headers-4.4.0-81-generic
They will be in /usr/src/linux-headers-4.4.0-81-generic/

Then, continue with the VB setup.

So I’ve reinstalled Mate and Virtualbox and was now able to run /sbin/vboxconfig successfully. I can now start a VM and it seems to work correctly.

However, now when booting up, after the motherboard flash screen I get a grub> prompt.

                         GNU GRUB version2.02 beta 2-36ubuntu3.11
         Minimal BASH-like line editing is supported.........


Can anyone tell me why this is happening?