VLC Complications With Sound Settings Applet

Hi everyone,
Past couple of weeks since I installed this OS, I’ve been noticing an occasional, yet ongoing issue with VLC. After quitting it after some video playback, sometimes the media controls will remain under the sound menu. At this point, my audio applet is rendered completely unusable. Selecting Sound Settings does nothing, and adjusting the volume mixer also does not work. These settings, if accessed in Conreol Centre are fine. Logging out or resetting panel layout seems to correct it for that time of happening. I uninstalled VLC for a while and went to SMPlayer, it was fine the entire time being used. Back on VLC, and it happens again after a day. I’m a VLC patriot, so can’t let it go :grin:
So not sure if this is VLC or desktop at fault. Can’t find this with any other configuration, so turning it to you guys.
I use Ubuntu MATE 14.04.2. No manual updates or anything to stock applications. Just whatever the updater lists. VLC is at 2.1.6.
Any similar experiences or known fixes?
Any insight is appreciated.

@11ryanc I’ve not noticed this before but I’ll do some tests and see if I can reproduce it. From what you describe it sounds like VLC is the cause.

Yeah, that was my initial thought too. To be fair, not hip with where VLC is going to some degree. Lot of patches, lot of breakage. Reproducing this is kind of complicated. Happens and it doesn’t. However I did do one thing that seemed to spike it. The audio mixer in VLC can go beyond 100%. It can also be set to some strange levels, such as 102% vs. 100. I had it unevenly set, and adjusted it. That produced the problem immediately it seemed.
Update: Speaking of such, it’s happening right this moment, ironically.

Hi,

try installing the package “paman” and use the Pulse Audio Manager to check your sound settings:

sudo apt-get install paman

http://www.freedesktop.org/wiki/Software/PulseAudio/

You think this may be sound driver related? On a second note, can’t get SimpleScreenRecorder to pick up system audio, no mater what the setting selected.

Could be, do you have codecs such as "faac" and "flac", "libavcodec-extra","libxine2-all-plugins" installed, maybe they might help too?. :smiley:

Install the lot, it won't hurt!:

sudo apt-get install faac flac libavcodec-extra libxine2-all-plugins

In your software settings, "Canonical" should be ticked and I would use "Main" as the "Download from" source!:

Installed. Showing me an error notification that I have “Unmet dependencies”.

Then change your “download from” location to something else and reload the software list!. :smiley:

K. Seems to work anyway. Just what is it we’ll be using this for?

They are just support packages for audio playback, although VLC is pretty complete, if your system doesn’t have a certain codecs installed, it won’t work correctly!. :smiley:

I’m sure that there is a better technical description but I know what it is!. :smiley:

Alright. Appreciate the help everyone :relaxed:
I don’t believe this will solve VLC, as this was more of a crashing scenerio. Actual playback was and performance couldn’t be smoother. I did have one last question though. For screen capture purposes. What kind of sound settings would I apply to record system audio? Built In Analog via PulseAudio doesn’t seem to work. Tried everything in the list. It could just be a complication with the program itself, but just trying to make sure it’s not a faulty driver.

Try removing and reinstalling VLC:

sudo apt-get remove vlc && sudo apt-get install vlc

Oh VLC’s already gone from the system. I’m using SMPlayer for the moment, 14.9.0 to be precise. Got the PPA from their website.

Ok I messed something up… Since I did not need the Pulse Manager, as pointed. I tried flushing it from the System. Firstly by removing paman from Synaptic. That was unsuccessful. After that, I completely uninstalled Pulse with sudo apt-get autoremove pulseaudio I thought that would only remove the manager I just setup, but it totally wiped system sound and I am left with no audio. Reinstalled, and still no access to volume.
Sorry guys. I know this waay off topic from the thread started. I’m probably just going to format and start over on 15.04. I’d like to try that out anyway.

I would look here for a good amount of info about Pulse:

http://www.freedesktop.org/wiki/Software/PulseAudio/

See also:

https://help.ubuntu.com/community/SoundTroubleshooting

https://help.ubuntu.com/community/SoundTroubleshootingProcedure

I see. Well I’m on a fresh install of 15.04, just updated everything. Working beautifully :relaxed:
Back to VLC. I see the audio indicators, in general are changed here. No longer a full menu like it was. VLC shows a tray icon, and quits when expected. So that’s good. I’ll watch over it closely, and if anything happens. I will screencast and document it all back here.

1 Like