VNC server issues

Hello MATEs, I am new to the forum and MATE so please bear with me. I just started with MATE and I have to say I like it.

Now I am trying to setup VNC server and I am being concerned about the number of warnings/errors I see in the VNC log file when starting the VNC server. Most of them were dbus related and I was able to eliminate most of them by disabling the following services from startup: power manager, screensaver, blueman applet. As this is MATE running as VM on ESXi and everybody will VNC to it, I do not believe I will need them.

One of the fix I tried was unseting the DBUS_SESSION_BUS_ADDRESS in VNC xstartup file but that did not make any difference.
This is the current log file:

XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
Xvnc TigerVNC 1.7.1 - built Jan 19 2017 18:40:31
Copyright (C) 1999-2016 TigerVNC Team and many others (see README.txt)
See http://www.tigervnc.org for information on TigerVNC.
Underlying X server release 11804000, The X.Org Foundation


Thu Feb  2 16:53:48 2017
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on all interface(s), port 5902
 vncext:      created VNC server for screen 0
mate-session[2677]: WARNING: Unable to find provider '' of required component 'dock'
SSH_AUTH_SOCK=/run/user/1000/keyring/ssh
SSH_AUTH_SOCK=/run/user/1000/keyring/ssh
no maximize: true
grep: /home/seclab3user/.xinputrc: No such file or directory
SSH_AUTH_SOCK=/run/user/1000/keyring/ssh
/usr/lib/python2.7/dist-packages/gi/overrides/Gtk.py:50: RuntimeWarning: You have imported the Gtk 2.0 modul
e.  Because Gtk 2.0 was not designed for use with introspection some of the interfaces and API will fail.  A
s such this is not supported by the pygobject development team and we encourage you to port your app to Gtk 
3 or greater. PyGTK is the recomended python module to use with Gtk 2.0
  warnings.warn(warn_msg, RuntimeWarning)
sys:1: PyGIWarning: Caja was imported without specifying a version first. Use gi.require_version('Caja', '2.
0') before import to ensure that the right version gets loaded.
/usr/lib/mate-optimus/mate-optimus-applet:7: PyGIWarning: Gtk was imported without specifying a version firs
t. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk, Gdk
Initializing caja-main-menu extension
Initializing caja-open-terminal extension
** Message: Initializing gksu extension...

(nm-applet:2791): nm-applet-WARNING **: GDBus.Error:org.freedesktop.NetworkManager.AgentManager.PermissionDe
nied: An agent with this ID is already registered for this user.

(nm-applet:2791): Gdk-CRITICAL **: gdk_window_thaw_toplevel_updates: assertion 'window->update_and_descendan
ts_freeze_count > 0' failed
Error executing command as another user: Not authorized

This incident has been reported.

XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

Any help/advice is appreciated.

Hello
Please specify what version of Ubuntu MATE you are using.
Cheers

Hi ouroumov,

It is MATE 16.04
Taken from lsb-release:
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION=“Ubuntu 16.04.1 LTS”

I just noticed another strange behavior. I cannot edit any network connections within Network Manager. However, if I run MATE as DE add on on Ubuntu or even Centos, network connections are editable.

Thank you.

Have you tried other VNC servers such as TightVNC, or the standard Vino? (Is it an option?)