Volume control applet

Hi All

Somehow I lost my volume control applet in the notification panel in the top panel. What would be the best way to try and recover it?? I searched the web and tried their fixes but none worked so far. I tried putting gnome-volume-control-applet in start up, didn’t work. Tried to type GVCA into terminal it tells me no such command. I would appreciate a fix for this problem. I was dabbling in mate when this happened.
Thank You for your time.

Do you have indicators enabled in your panel (through MATE Tweak)? If so, check that the indicator-sound package is stil installed. If it is, try to disable/re-enable activators (you might have to change the panels setup) and/or reboot.

If you don’t use indicators, try to start mate-volume-control-applet (not GNOME’s one) and check that it’s in your startup applications.

Thank you terzag for the info. I don’t understand how to enable panel on mate tweak?? I couldn’t find that option. I did put “Mate-volume-control-applet” in startup applications and that worked. Thanks. Here is something interesting. Finally before I came to this site, I restored back with Timeshift to an earlier version with both system and home directory restorations. But I still didn’t have the volume control applet. I knew I had it before in the earlier version of timeshift. Any thoughts on this. I thought I would get the volume control applet with an earlier version.

Just wanted to say that I think Mate distro is an excellent choice. There have been a few hiccups but nothing serious.
Thank You:

You don’t enable the panel in MATE Tweak, it’s already on your desktop, that’s the bar(s) with applets, the clock and so on. What you can do in MATE Tweak is enable or disable the indicators, which is an alternative made for Ubuntu a few years ago to replace the system tray (the status icons like volume control, network status…). Note that with MATE Tweak, you can select various desktop layouts (e.g. one with one panel on top and one on bottom, one that copies the layout of Ubuntu’s Unity… some use the indicators, some don’t).

In other words, on Ubuntu MATE, you have two possibilities for status icons: either you use the systray or you use the indicators.
If you use the indicators and the volume control is missing, it could be that the related package has been uninstalled for some reason (indicator-sound −basically, each indicator is installed through its own package and the panel displays all those that are installed). If you use the classic systray, it’s probable that the control applet isn’t launched.

Currently, you’ve fixed the issue by running the volume control applet at system startup. But it would be a good idea to check if you use indicators overall, as maybe you currently have a mix of indicators + the volume control in the systray where you sould have an indicator for the latter.

My Mate tweak doesn't show some options that I see in online videos. Like I don't ave an option to load the advanced menu etc. My computers are pretty old 32 bit, single core processors, 2GB memory. Maybe this is some of the problem. I even tried to load up a live usb of Ubuntu 17.10.01 and get the same results. Have you seen any thing like this Mate in Tweak tool? I'd show you .png of my mate tweak interface pic but I don't know to do that here.

Ok I figured out how to send an inage, here it is.

I’m not sure what version you usually use (16.04? 17.10? other?) and the MATE Tweak interface might have changed a bit over time (I’m note sure) but the screenshot you show is the same as what I have in 17.10. The options for indicators and layouts I’m talking about should be in the Panel section, not Interface.

Here is the latest versionof Mate on this computer;

VERSION="17.10 (Artful Aardvark)"
PRETTY_NAME="Ubuntu 17.10"

Here is the panel on Mate Tweak: Nothing on selecting advanced menus ETC that I can see. Unless I'm missing something :relaxed:

Here is the Windows pic in mate tweak:

Oh yeah, I didn’t check before replying and had the old version of MATE Tweak in mind. So, good news: your version is fine; bad news: the option to enable indicators has been removed. I’m not sure how you enable them now, I think you have to select a layout that has them, like Mutiny or Pantheon (from then, you can customize the layout how you want and save it as a custom version).

Oh ok I guess I’ll keep trying and see what I can do. Do I have to install python or mutiny to move forward? How do I proceed?


No, nothing to install, Mutiny and Pantheon are presets layouts that you can choose from the drop-down menu where you see “Traditional” (in the Panel section).

They’ll load specific layouts: e.g. the Mutiny one is made to look like Ubuntu’s Unity, with a top bar and a panel/dock on the left; Pantheon is made to look like elementaryOS I think. Some of the layouts use indicators, others (like Traditional) don’t.

Once you’ve loaded a layout, you can customize it as you want (add/remove panel, applets and so on) and when you have something that you like, you can save it with the Save As button so it’ll appear in the drop-down menu with the others.

OK terzag will give it a try. Thanks for everything it is well appreciated.


Everything worked out OK. Now somehow I have the Universal Access icon in the notification panel on top and can’t take it off. Right clicking dies nothing and left clicking gives me the preferences window??? Do you know how to get rid of the Universal Access icon? Tank you.

Have you checked in the system settings (control center) → Acessibility if the tools are disabled?

With your description, I can’t say if you have an indicator or a systray icon: is the icon in black & white or colored?

Icon is blue and white next to synapse icon I think, not at my computer right now.

Ok, so unlikely that it’s an indicator. So, check in the system settings as I said when you can.

How do you get to system settings in ubuntu mate 17.10 In control center it says assistive technologies is that the same as universal Access? I'm totally confused.

My Ubuntu MATE is in french, so I didn’t know the english names and thought you’d figure out. :wink:

By system settings, I meant the Control Center. What I named Universal Access is indeed Assistive Technologies. Launch it and you should see an option like “Enable assistive technologies” or whatever. It it’s checked, disable it and see if this removes the systray icon (you might have to restart the session).

If the option is already disabled, check in your startup applications if you have something that might fit (“assistive technologies applet” or a similar name).

Here are some more snapshots of what I looked at to try and remove Assistive Technologies from right side of my upper panel.

Here is my top panel for you to enjoy:slight_smile: