What happened to the Clock applet!?

In 19.10 I noticed to my great dismay that the absolute best Clock applet that was the unique part of the MATE desktop has disappeared! Is this just in Ubuntu MATE, or MATE in general?? I cannot stress enough how marvellous the clock applet was, with its little world map, with all the locations, showing where the sun is shining everywhere on earth.

Did you know that very few distros have a workable world clock?? The lack of a good world clock makes desktops like XFCE and Gnome completely userunfriendly to me. Is it now only Trinity that is left with the winning world clock applet, or does original MATE still have it?

Why did it get removed??


It's just removed from the default appearances, because the date time indicator integrates better and gives a more consistent feel, (a move which I personally really like) but if you want it back right click on the panel, add to panel, clock, add and if you don't want the date time indicator either remove it from start up applications or uninstall it


The clock applet is still there, it's just the default panel layout now uses a clock indicator instead. You can add it manually by right-clicking on the panel and adding a new applet.

I personally prefer the traditional clock applet, which I use a lot because I work across multiple timezones and need to have a bunch of world clocks at a quick glance.

The new indicator one, however, links to the evolution calendar backend and shows appointments and such, which is a really nice feature. So for now I actually have both enabled :smiley:


I like the traditional one, also. But as @Bernie suggests, the new date-time-indicator cannot be removed permanently from startup apps without hacking at ~/.config/autostart or /usr/share/mate/autostart files. Some kind of permissions issue has been causing this on several startup apps for a while.

Am I missing a configuration for the new date-time applet? Like showing date and seconds?

1 Like

As far as the configuration goes it has to be done in the dconf editor currently, let's hope that changes


Thanks, good to know. That's probably easier than editing .desktop files.

Just for the record, the issue is unchecking some items such as "Indicator Date & Time" or "MATE HUD" in Startup Applications will not last 2 boots.

1 Like

the new date-time-indicator cannot be removed permanently from startup apps without hacking

You should be able to disable it by going to the Startup Applications and unticking the appropriate indicator box. Might need a session restart after that.

Hi @vkareh. It doesn't survive reboots - same for many others has been this way for many versions. It'll appear to work for 1 reboot but the setting will be reinstated. Are you seeing different?

Glad to hear the old Clock applet is still there, and this is just a matter of defaults. I don't intend to start using Evolution as well, so I have no need for that integration. I'll just (re)configure my installs a bit more now.

... and uninstalling this date-time-indicator seems to be the most foolproof solution to get it to now show!?

Good question. I have plenty of items deselected and they don't
magically become enabled. Maybe an update to the ubuntu mate settings
base is overriding it during the Beta period?

On the other hand, none of the ones I have disabled are an indicator.
I have just disabled the date-time indicator and will test a bit to see
what happens on my side.

Indicators affected the most but I see HUD has the same behavior.

Hi I somehow have the opposite problem. The indicator-datetime has randomly disappeared from the indicators and I can't get it back. I've tried everything i can think of, resetting the panel, restarting, even trying to reload the layout in ubuntu-tweak (annoyingly that now saves the previous settings which is great, but what if those settings are borked?)

When I log in it shows up for a split second and then goes away so something is hiding it. I just can't find it. The indicator applet isn't very configurable... or at least easily so...

I tried poking around in dconf-editor /com/canonical/indicator/datetime. Weirdly show clock is enabled. Turning it on or off does nothing. Something is really borked with the indicator...

Welcome @Joshua_Pettus! Have a look in :monitor: System Monitor to see if indicator-datetime-service is actually running.

Try running it through the terminal to see if it outputs any errors:


If you see these warnings, this is normal:

** (process:2497): WARNING **: 12:09:56.267: could not find the desktop file for 'org.gnome.Calendar.desktop'

(process:2497): Indicator-Datetime-WARNING **: 12:09:56.274: indicator-datetime cannot show EDS appointments: Error calling StartServiceByName for org.gnome.evolution.dataserver.Sources5: Unit evolution-source-registry.service not found.

You might want to open a new topic on the case. :slight_smile:

Edit: New topic:

Thank-you so much! I'm good with a bash shell, but it's the GUI stuff that kills me XD. I will do just that. For what ever reason I was having a lot of difficulty finding any documentation on it.

I added back the Clock applet. Since it simply works.
Then the Panel disappeared. Had to relaunch... but the Clock wasn't there anymore. Had to reinstall again, with all the cities I need to keep track of.
Can someone explain why it didn't remain there? Or was it the other evolution related clock that took over ?