What is the latest version of Virtual Box for UM?

VirtualBox was giving notices of an available update (5.1.18). I ran Software Updater and saw a Virtual Box update among several other required updates. I did not pay attention what version of VB was being offered. After updating this morning and restarting, I still received an updated notice from VB, but the Software Updater shows none available. My current version of VB is 5.0.36 r114008. What is the latest version of VB that is available for Ubuntu-Mate supported by PPA?

There’s two “series” VirtualBox versions, you must have 5.0 installed:

  • virtualbox-5.0 = 5.0.36
  • virtualbox-5.1 = 5.1.18

You can easily uninstall the 5.0 package and install 5.1. Re-installing in Software Boutique should do the trick. The PPA have both these packages.

Thanks. I will.

But I am curious of two forks. I believe I used Software Boutique last April to install VB. Is there any plan to consolidate or will the two forks keep moving on for the life of UM16.04LTS?

Update: Looking at VB in Software Boutique, it appears to be for UM16.10

They’re not forks as such, it’s more or less about stability, like we have 16.04 LTS and 16.10.

  • 5.1 has newer and more ground-breaking changes.
  • 5.0 continues for a while, releasing any important updates. It’s probably intentional that users need to switch over to 5.1 when they’re ready.

But note that:

VirtualBox 5.0.x runs out of support, switch to VirtualBox 5.1.x!


I’m assuming the version provided in the standard Ubuntu repositories will be slightly different.

The Software Boutique does install 5.1 for 16.04 (with “subscribe for updates” or “use latest listings” enabled), 16.10 and beyond already use 5.1.

You can use the terminal too:

sudo apt remove virtualbox-5.0
sudo apt install virtualbox-5.1

I did something wrong, I updated Virtualbox from Synaptic, as it finished updating, the System was blocked, and then did not restart,
It’s better to do things well, because I had to reinstall Ubuntu Mate again.


Thanks. Removed and installed new version in less than a minute. All virtual machines and settings remained intact.

I did notice in the terminal one notice/error:

Processing triggers for libc-bin (2.23-0ubuntu7) …
/sbin/ldconfig.real: /usr/lib/nvidia-375/libEGL.so.1 is not a symbolic link
/sbin/ldconfig.real: /usr/lib32/nvidia-375/libEGL.so.1 is not a symbolic link

Not sure if this really matters.

Is this the best way to manage VB going forward. I see 5.2 is out, Botique does not offer v5.2. Synaptic Package Manager shows both 5.1 and 5.2, but Mark All Upgrades and fixing broken packages still does not provide the upgrade. The other option is to install the deb file that Oracle offers when opening VirtualBox. Just looking for the best way forward in keeping VirtualBox up to date.

VirtualBox is a bit different where they distribute their major versions as separate packages, particularly as the old version is still supported for a while too.

You may wish to subscribe to their “announce” mailing list to stay informed when they release a new version and use that as the cue to swap packages.

It should be noted that 5.2 uses some new Qt thing under the hood, so it doesn’t look good in 16.04. :frowning:

Ubuntu MATE 17.10 PC

  • removed VirtualBox 5.1.30 using sudo apt-get purge virtualbox
  • installed VirtualBox 5.2.6 (based on the instructions here: https://www.virtualbox.org/wiki/Linux_Downloads)
  • installed VirtualBox Extension Pack 5.2.6-120293
  • started VirtualBox 5.2.6
  • old VM (Windows 10 - let’s call it VM-W10) was available in the list of VMs (???)
  • started VM-W10
  • installed the VirtualBox Extension Pack in VM-W10
  • rebooted
  • re-installed the VirtualBox Extension Pack in VM-W10 (because it looked like it doesn’t work as expected, cursor and keyboard were not captured)
  • rebooted

VM-W10 works as expected.

The following did work for me:

sudo apt remove virtualbox-5.1
sudo apt install virtualbox-5.2

Not just in 16.04, but also in 17.10 it does not match the selected theme.
My biggest gripe is that the Dock applet for the panel does not display the indicators for open VirtualBox windows properly anymore with 5.2.
This happens in both 16.04 and 17.10 as well.

U-M 16.04 on a 5th generation i7 Dell desktop and 5.2 was a disaster so reverted to 5.1 where I am now. I tried everything from host and guest graphics, kernels, options, VBox utilities and 5.2 runs ridiculously slow doing certain things on Linux guests every time.

I still can’t believe others aren’t seeing it on 5.2.

I just tried it in a clean 17.10 and found the theme was working straight away :confused: However, I did have the problem on an Ubuntu 17.10 (GNOME 3) system and found a solution - instructions written up here that may help:

Sorry, I got that mixed up with the other issue. I re-checked 17.10 and the theme does indeed match.
The dock still misbehaves, though - I hope that can be resolved for 18.04.

On the 17.10 version of Ubuntu Mate, I have Virtual Box 5.1.30 :wink: