Which drivers to use for AMD please

I have many problems and wonder if I have the wrong drivers for ubuntu mate 15.10 so which drivers are the correct ones to use please?

an example of “problems” is that my vizio 55" is getting detected as a 44" for some reason and I can’t see how to fix it.

Another issue is that when streaming, from XBMC/KODI, I get a split screen slightly offset horizontally across the middle of the screen when there is a lot of action.

SO if anyone can tell me which drivers I should be using I would be very grateful I’m hoping I can figure out the rest from there.

Original post was about Nvidia not ATI/AMD, deleted all references to Nvidia!.

See further posts below!. :smiley:

AGAIN with a wonderful response and so close to christmas! Happy holidays to you and yours Wolfman. Not even I can mess this up especially as you took the time to add in the steps. Thank you so much. I will certainly try it out and get back to you.

happy christmas Wolfman

2 Likes

And a Merry Crimbo to you too!. :smiley:

The “split screen” effect you described is screen tearing. I had this problem before, which was solved by adding TripleBuffer to a config file. This may work for your card too.

Compiz also helped than using Marco as a desktop compositor.

You can also optionally add the official Ubuntu NVIDIA drivers PPA which will update the drivers to the latest version – effective if your card is quite recent and not an older card using the “legacy driver”.

2 Likes

Good one @lah7:relieved:!

This never helped, for me, on ‘non-MATE’ distros; and that is why I did not experiment with this tweak (on the particular PC at issue) when I switched to U-MATE.

Something so simple can, often, do the trick; I hope @wolfman has this in his latest tutorials, because it can be a hair-puller :astonished:

The MATE community is the best :raised_hands:; am I right?

:santa: :santa::santa:

1 Like

Hi wolfman
sorry to report that I can no longer run software-center remotely using win7 remote desktop. I swear I fixed this issue a few days ago and now it’s back. VERY demoralizing! just mentioning it as this might be one of the reasons people give in and go back to windoze.

ANYWAY ran lspci ( thanks for the reminder :-))
and this was the result
1:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series]

it’s this physical card

ALSO I don’t have a /etc/X11/xorg.conf file anywhere on this machine which is ALSO troubling. I suppose I am a smidgen unhappy as this is more trouble than I expected. It reminds me of the bad old days when I had to compile and NDIS stack for our ungermann bass network cards :slight_smile:

I’d like to thank all of you in the MATE community for trying to help me out and I agree with @mated that the community is GREAT

3 Likes

(1) You won’t have a /etc/X11/xorg.conf – those went away (except for some very special cases) some time ago.

(2) Your card is a Radeon “Cedar” supported by the radeon Kernel module:
/lib/modules/4.2.0-22-generic/kernel/drivers/gpu/drm/radeon/radeon.ko
and by the Xorg “xserver-xorg-video-radeon” driver.

(3) “Vizio 55 being detected as 44” might be how the EDID is coded (it may be the same
controller hardware for the 44 and 55 inch models).

(4) Look at /var/log/Xorg.0.log – you should see

(this is for my Insignia TVs / Best Buy specials:)
[ 36.149] (II) RADEON(0): EDID for output HDMI-1
[ 36.149] (II) RADEON(0): Manufacturer: BBY Model: 32 Serial#: 1
[ 36.149] (II) RADEON(0): Year: 2012 Week: 30
[ 36.149] (II) RADEON(0): EDID Version: 1.3
[ 36.149] (II) RADEON(0): Digital Display Input
[ 36.149] (II) RADEON(0): Max Image Size [cm]: horiz.: 41 vert.: 23
[ 36.149] (II) RADEON(0): Gamma: 2.20
[ 36.149] (II) RADEON(0): No DPMS capabilities specified
[ 36.149] (II) RADEON(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4
[ 36.149] (II) RADEON(0): First detailed timing is preferred mode
[ 36.149] (II) RADEON(0): redX: 0.663 redY: 0.325 greenX: 0.285 greenY: 0.613
[ 36.149] (II) RADEON(0): blueX: 0.140 blueY: 0.067 whiteX: 0.280 whiteY: 0.290
[ 36.149] (II) RADEON(0): Supported established timings:
[ 36.149] (II) RADEON(0): [email protected]
[ 36.149] (II) RADEON(0): [email protected]
[ 36.149] (II) RADEON(0): [email protected]
[ 36.149] (II) RADEON(0): [email protected]
[ 36.149] (II) RADEON(0): [email protected]
[ 36.150] (II) RADEON(0): Manufacturer’s mask: 0
[ 36.150] (II) RADEON(0): Supported standard timings:
[ 36.150] (II) RADEON(0): #0: hsize: 1280 vsize 720 refresh: 60 vid: 49281
[ 36.150] (II) RADEON(0): #1: hsize: 1280 vsize 800 refresh: 60 vid: 129
[ 36.150] (II) RADEON(0): #2: hsize: 1280 vsize 800 refresh: 75 vid: 3969
[ 36.150] (II) RADEON(0): #3: hsize: 1280 vsize 960 refresh: 60 vid: 16513
[ 36.150] (II) RADEON(0): #4: hsize: 1280 vsize 1024 refresh: 60 vid: 32897
[ 36.150] (II) RADEON(0): #5: hsize: 1440 vsize 900 refresh: 60 vid: 149
[ 36.150] (II) RADEON(0): #6: hsize: 1680 vsize 1050 refresh: 60 vid: 179
[ 36.150] (II) RADEON(0): Supported detailed timing:
[ 36.150] (II) RADEON(0): clock: 85.5 MHz Image Size: 484 x 272 mm
[ 36.150] (II) RADEON(0): h_active: 1360 h_sync: 1616 h_sync_end 1728 h_blank_end 1792 h_border: 0
[ 36.150] (II) RADEON(0): v_active: 768 v_sync: 786 v_sync_end 792 v_blanking: 795 v_border: 0
… etc …

1680 x 1050 is listed but the TV or Radeon won’t go to that resolution.

djb

Hey Dave
sorry to drag you into my nightmare :slight_smile: I was looking where to add TripleBuffer to a config file as the lads here suggested BUT I don’t know which file to add it to ALSO I have no idea how to determine which drivers I am really using. And FINALLY I am struggling to get hdmi 5.1 surround out of this card to a media program called Kodi so I can pump the signal via a Vizio e55i using the ARC protocol to a sony dn 1050 receiver

I REALLY REALLY REALLY wish that this was all just a little easier :slight_smile: BUT the great folks here (yourself included) are making me stay the course. Vizio just basically told me to return the sony and use their sound bar but I don’t give in that easily :slight_smile: t

It shouldn’t be that hard:)

This sounds like a media center configuration issue and not Ubuntu
MATE. If you want to go off list to discuss, I’ll try to walk you
through what should work.

djb

It looks like the “Cedar” only supports 2 channels:(

djb

Hey Dave
I just went into the audio settings for the graphics card and in the drop down it has a 5.1 option, so I checked that and tried the test speaker and the left and right front work fine but all the others just get a click and nothing else.

SO could it be that the card CANNOT support 5.1 yet the driver will? How did you find out that the card doesn’t support 5.1?

I also am not sure how I can check which driver I should be using AND if I am?
I followed wolfman’s instructions about finding the drivers and which cards they support BUT my card wasn’t on the list.

how do I go off list remember I am a noob

Did you look at /var/log/Xorg.0.log ?

The card supports 7.1 but I don’t know if the Linux drivers support more than 2.

djb

Hi Dave
not sure what I am looking for in the /var/log/Xorg.0.log file

AND to add insult to injury I set the window manager to compiz and the fracking terminal window locks onto the top left of the remote desktop screen and won’t move under any circumstances! This undoes the setting that corrected the screen jag problem. ON top of this when I am remote desktopping the Mate Tweak Appearance setting does NOT list compiz though when I go to the actual machine it does. I mention all of this not because I am looking to solve it, just as an example as to how frustrating this OS can be to a noob like me.

Check your messages.

djb

Recommended configuration for X.org:

No configuration is necessary for ATI driver in the modern versions of Ubuntu. You can safely take away your /etc/X11/xorg.conf and your computer should run fine. Check the manpage of the Radeon driver for advanced options.

Open a terminal and run:

man radeon

See the following links for more info:

https://help.ubuntu.com/community/RadeonDriver

Did you install the fglrx driver?, it needs to be removed!:

https://wiki.ubuntu.com/X/Troubleshooting/VideoDriverDetection#Problem:Need_to_purge-fglrx

See also:

http://wiki.x.org/wiki/RadeonFeature/

thanks wolfman the great Dave_Barnes is working with me step by step to find out what is going on. He is GREAT and thanks for your help. A few things that are demoralizing to a newbie

1 there is SO MUCH disinformation out there on the web it is difficult to know who to trust for reliable information. I have a vanilla install BUT I WAS going to install the fglrx driver based on google research. that’s an example of a problem caused by noobs trying to get it fixed.
2 one step backwards all the time. So I can’t select compiz from the remote desktop I have to be at the machine, BUT when I am at the remote desktop the terminal window locks to the top left and I have to turn OFF compiz in order to do anything on the remote so it’s back and forth all the time.
3 I “thought” I had fixed the ability to run software-center on my remote desktop but that had gotten rebroken somewhere along the line and I don’t know how.

4 now the Maximize/Minimize/Close icons are disappearing on me which means I cannot close windows without a reboot.

5 NOW I find out that my favorite cheese has been overbought and stocks are low so the price just quadrupled! I suspect Mate is to blame :slight_smile:

I am NOT looking for solutions to these problems just pointing out that right now most people would be RUSHING back to microsoft. The MATE commmunity is a the ONLY reason I am staying the course right now. You folks are GREAT

Help is only effective when things are taken one step at a time by using seperate threads for different problems. I changed the thread’s title, as you have an AMD card. Posts (like mine earlier) are specific only to NVIDIA and won’t work on your system. In fact, trying to mix them up just confuses things and could break the graphics in the process. :frowning:

When you have a system where everything “just works” from a fresh install, that’s the best thing. :smile: One strength with Windows currently is that it’s pre-installed and ready to use, Windows from scratch use to take me hours to get everything exactly the way it was! :expressionless:

The remote desktop is different…

If you’re using xrdp to connect via RDP, there are some differences, such as the lack of hardware acceleration which causes Compiz and Kodi to fail. Instead of Compiz, you’ll need to load Marco – If it is xrdp, then the command:

marco --replace

Can be added at the end of /etc/xrdp/startwm.sh (I believe) or loaded when you logon remotely.

Hey Lah7
gotcha on the thread bundling issue, I wanted to show the frustration in context and not find solutions, I did say that in the thread I think. As to the Nvidia vs AMD issue I really honestly believed I had an Nvidia card in there so sorry my bad. I AM using xrdp and windoze remote desktop to connect as my googling ( meddling) said it was the chosen one SEE noobs can make things worse! ANYWAY point taken and thank you for all your excellent help. I wish you and yours a happy xmas and a very happy new year.

I’m off now to burn the machine to the ground and buy a microsoft surface on the proceeds of the youtube video I will make :slight_smile: just kidding

1 Like