Wifi not working

hi @wolfman . so still trying to get this wifi to work , it is a wna-3100 wireless-n 300 , i have seen some info saying that i need a broadcom driver. bcmwl-kernal-source , is the info i have , dont know what to do with it , but hay im a bit closer to figureing it out. also windows driver is bcmwlhigh6.inf , thought i could use that with the windows driver installer for ubuntu , but that didn’t work.

Hi Bill,

take a look here and see if it helps, you can identify your chip first and then work from there!:

https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx

See also:

https://help.ubuntu.com/community/WifiDocs/WirelessTroubleShootingGuide

i read the links and tried what they said , but I am clearly missing something or not giving you the right info . here is what info i got from usb-devices
T: Bus=08 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#= 2 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=ff(vend.) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=0846 ProdID=9020 Rev=00.01
S: Manufacturer=Broadcom
S: Product=Remote Download Wireless Adapter
S: SerialNumber=113
C: #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=200mA
I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=02 Prot=ff Driver=(none)

I cant figure out what chip i have from that info. oh yea and thanks very much for your help , i’m on day 3 close to 4 on trying to get my wifi working and still have to figure out why i have no sound and connect my printer and so on and so on. but one thing at a time .

@Brutal_Bill, I’ve split your posts to a new topic, please open new topics when you have an issue so as not to derail existing ones. :]

Also since you have a Wifi issue, please provide the output of the following command in a terminal (CTRL+ALT+T):

sudo lshw -C net

You’re coming in from windows, so be aware that when you type your password in a terminal you won’t see stars echoed back to you - this is normal, just keep typing then hit Enter.

Furhter to @ouroumov’s suggestion, I believe you have the Broadcom 43xx series chip so open a terminal and paste the following terminal command (Ctrl + Alt + t) and then reboot:

sudo apt-get install broadcom-sta-common

RESTART!.

If after a reboot; it doesn’t work, try the legacy package and remove the other one with the following terminal command:

sudo apt-get remove broadcom-sta-common && sudo apt-get install firmware-b43legacy-installer

RESTART!.

and if the above doesn’t work, remove it too with the following command:

sudo apt-get remove firmware-b43legacy-installer

From https://wireless.wiki.kernel.org/en/users/Drivers/brcm80211

1 Like

Hi Bill,

looks like you are out of luck, take a look at the list here if you need to buy a new one and make sure it is in the list of supported devices before you do:

https://help.ubuntu.com/community/WifiDocs/WirelessCardsSupported

Otherwise, take a look here if you have the WINDOWS DRIVER DISK:

lol, yea the password thing got me the first time, took me a couple of minutes to figure out what was happening. also thanks for splitting the posts i’m new to all this . thanks for the help.

*-network
description: Ethernet interface
product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: [email protected]:02:00.0
logical name: enp2s0
version: 0c
serial: 40:8d:5c:e2:b8:f8
size: 10Mbit/s
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168g-2_0.0.1 02/06/13 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
resources: irq:44 ioport:e000(size=256) memory:fe900000-fe900fff memory:d0800000-d0803fff
*-network
description: Ethernet interface
physical id: 1
logical name: enx00a0c6000000
serial: 00:a0:c6:00:00:00
capabilities: ethernet physical
configuration: broadcast=yes driver=rndis_host driverversion=22-Aug-2005 firmware=RNDIS device ip=192.168.1.4 link=yes multicast=yes

Hi Wolfman ,
thanks for all your help. I brought a new one last night before I had seen your post , it said it worked with linux and i just checked now and its not on the list ,lol. its not branded but looking at the specs “realtek 8191” I’ll give it a go when it gets here.

FYI, just incase anyone else is using a NETGEAR AIRCARD 810S , please note that it will NOT network between computers, printers, tv, or nas drives. it is a firmware problem and has nothing to do with your os.
also if tethered to you pc , it will make a new network every time the pc is restarted or turned off.
also can not be used as 3g/4g back up on a modem/router.
the only way to network it is to buy the $280 cradle for it.
Or connect to it using wifi from your pc and then share that internet connection with others on that network, use a modem and put it in bridge mode and you should be able to get internet to your none wifi computers and stuff.

Hi Bill,

take a look here as it may well work as Ubuntu is Debian based!:

https://wiki.debian.org/rtl819x

1 Like

awesome , finaly some good news . my new one should be here in a couple of days . I will let you know how I go . thanks for your time and effort.

1 Like

@wolfman
hi wolfman
I got the new usb wifi , chipset 8191 . I went to realtek site and downloaded the linux software for it. (r8152-2.07.0) and now have no idea how to install it.

@wolfman
hi wolfman I went on chat and got some more help and got put onto a package to sort it out . and now it works \o/ here is the link to help out anyone else having same issue with realtek chipset 8191 wifi usb dongle.
https://sites.google.com/site/easylinuxtipsproject/reserve-7#TOC-Realtek-RTL8192EU-chipset-0bda:818b-

I have a wifi dongle that I need to get working . it has no brand and said on the packet it works with linux , but i cant get it to work. it has chipset 8191 . I’m running ubuntu mate 16.04 .
I went to realtek site and downloaded the software for it (I think) but have no idear what to do with it.
R8152-2.07.0. is the name of the file i downloaded.
please help I’ve been at this for over a week.

What is the USB ID of the dongle? In a terminal, use “lsusb” to get a list of USB devices and paste the info for the WIFI dongle here.

hi dave , I have just sorted out the driver thanks to some help on the chat thing. I will post link to help anyone having same problem with the 8191 chipset .

here is the link that has a package that will install the driver needed for chipset 8191 realtek .
thanks to everyone who helped me get this sorted.

An open source driver is in the works:
http://cateee.net/lkddb/web-lkddb/RTL8XXXU.html
The new driver is not yet ready for general use however.

Glad you got the old one working.