Wireless Drivers HP Pavilion

I have an older computer, an HP Pavilion ze5400 that I just started using Ubuntu Mate with. Anyone know how I could get the wireless/ethernet cable & other drivers working?

Can you post the output of the command

lspci -nn

please.

See also:

Thanks for the replies, here’s what it reads:

[email protected]:~$ lspci -nn
00:00.0 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD/ATI] RS200 Host Bridge [1002:cbb2] (rev 02)
00:01.0 PCI bridge [0604]: Advanced Micro Devices, Inc. [AMD/ATI] RS200/RS250 AGP Bridge [1002:7010]
00:06.0 Multimedia audio controller [0401]: ULi Electronics Inc. M5451 PCI AC-Link Controller Audio Device [10b9:5451] (rev 02)
00:07.0 ISA bridge [0601]: ULi Electronics Inc. M1533/M1535/M1543 PCI to ISA Bridge [Aladdin IV/V/V+] [10b9:1533]
00:08.0 Modem [0703]: ULi Electronics Inc. M5457 AC’97 Modem Controller [10b9:5457]
00:09.0 Network controller [0280]: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller [14e4:4320] (rev 02)
00:0a.0 CardBus bridge [0607]: O2 Micro, Inc. OZ601/6912/711E0 CardBus/SmartCardBus Controller [1217:6972]
00:0b.0 USB controller [0c03]: VIA Technologies, Inc. VT82xx/62xx UHCI USB 1.1 Controller [1106:3038] (rev 50)
00:0b.1 USB controller [0c03]: VIA Technologies, Inc. VT82xx/62xx UHCI USB 1.1 Controller [1106:3038] (rev 50)
00:0b.2 USB controller [0c03]: VIA Technologies, Inc. USB 2.0 [1106:3104] (rev 51)
00:0c.0 FireWire (IEEE 1394) [0c00]: Texas Instruments TSB43AB21 IEEE-1394a-2000 Controller (PHY/Link) [104c:8026]
00:10.0 IDE interface [0101]: ULi Electronics Inc. M5229 IDE [10b9:5229] (rev c4)
00:11.0 Bridge [0680]: ULi Electronics Inc. M7101 Power Management Controller [PMU] [10b9:7101]
00:12.0 Ethernet controller [0200]: National Semiconductor Corporation DP83815 (MacPhyter) Ethernet Controller [100b:0020]
01:05.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] RS200M [Radeon IGP 330M/340M/345M/350M] [1002:4337]
[email protected]:~$

Did you have a USB cable connected to the printer BEFORE you pasted the terminal command?. :confused:

No I did not. I am getting confused now, I was posting what Dave_Barnes asked. I think you might be mistaking the HP laptop that I have with an HP printer! I unfortunately don’t have a usb cable either, so I am at a stalemate. :sweat: I do have a printer, its a Lexmark. I am also able to get a wired connection, so all I truly need is the wireless drivers.

The ethernet interface is handled by the natsemi.ko kernel module. You can check if
the device has been recognized and the module loaded by:

lsmod | grep natsemi

Can you get the ethernet configured and on the Internet?

@LunarServerside,

Sorry, I for some reason saw the words “HP printer” and that is why I am babbling!. :frowning:

Its alright. :grin: Dave, in the terminal, “matsemi” is in red letters, followed by the numbers “36864”, and a 0. I am able to go on Firefox and browse and watch YouTube. I have never used any Linux operating system before and I really enjoy this one.

If you have an cable internet connection, try changing your software download location and running an update, you can also try the “Additional Drivers Tool” in the Control Centre to see if it finds the hardware?:

Thanks! Wifi works now.

1 Like