WP10 not mounted

Hello there,

I’m using ubuntu mate 17.04 (exclusively) on my 24" iMac.
When I try connecting my windows 10 phone via USB, and I have tried several times or used several cables,
my phone, or even my sd card are not mounted.

Any idea would be welcome!!

Thanks,
Yiannis

Hm, the question is whether this is MATE specific or not.

Can you try a live CD image of another distro such as stock Ubuntu?

Hi, thanks for trying to help.
I’ve been using ubuntu (unity) 16.10, same thing!!
This is really weird, the only explanation I can give is that maybe using linux on a mac may create problems with the os?
I don’t know, there were 2 times I just saw an icon, while I was trying different cables, but that’s it!

Do you maybe have to enable something on your phone to allow the mounting?

No, I have checked several times, maybe I will add another cable to my cable collection,
sometimes it gives me a message saying that it is not charged very well, or something like that…
Thanks, anyways!

1 Like

Success, I thought that maybe this issue had to do with the cables I used.
So, I bought a new one and tried again…same thing, unsuccessful, BUT
even though I get the message “unable to open MTP device”,
my phone appears on the Places menu on the upper panel, same thing with the other cables, so…
I really feel a little bit awkward about this, but now I can browse my phone and the SD card!!
Problem (not really) solved!!

1 Like

So, it just suddenly and magically started to work?

Nope, it was working all the time, and since the icon of my phone did not appear on the desktop, and the message “unable to open MTP device” was showing, I never cared to open caja…embarassing!!
cheers

1 Like