Write ISO image to USB

I have downloaded Balena Etcher as an appImage. I have no idea what to do with it. I tried downloading etcher from other package (non appImage) managers but cannot get it to open when installed. Then I down loaded Ventoy which comes in as a tar.gz file. I extracted it but don't have a clue how to get it to work. I am familiar with windows where you can click on an EXE file. I am dual boot and right now I need to reset windows because it refuses to connect to the internet. Thankfully my ubuntu mate connects. I need to write a windows 10 image to USB.

you can d/l win10.iso and use Disks to write it to a USB.

For appimages, you need to click on properties and enable it to run as a program.

1 Like

Still doesn't make sense. I enabled it to run, now what do I do?

To test I d/l balenaEtcher-1.18.11-x64.AppImage
It went to my Downloads/ dir.
Right click, properties, permissions, allow it to run.
double-click on the balenaEcher file ... it started.

1 Like

Those are the exact steps I followed, but double clicking does nothing.

Just confirming procedure by @pavlos_kairis it opens on my UM22.04.3 with appimage downloaded from:


Try hovering over icon and then right click / open

Also might try Control Center / Hardware / Disks as mentioned by pavlos, I use it.

1 Like

I do not have screens that look like that. I have a check box to "allow executing as program", but there is not anything to hover over. I was able to figure things out on the windows side to download etcher and use it. I would rather use linux but it's just not as easy sometimes. Hopefully I will not need another AppImage file for anything.