100% on one core, all the time (unless a USB device is plugged in)


I noticed today that lightdm is taking 100% of one of my cores constantly. I tried rebooting, but that didn’t help. I’m running on a System76 Lemur. Has anyone else noticed this issue?

What version of Ubuntu MATE? I haven’t noticed this myself.

Have you run a full system update?:

Sorry guys, I forgot to include the version. It’s Ubuntu MATE 15.10. I’ve already run all updates. Also, I’ve tried downgrading lightdm to the version prior to the current version, and that didn’t help.

Are any proprietary drivers in use? They can sometimes be a cause.

Where does it report lightdm is using 100%? Is it the same in both System Monitor and the top command (in the terminal)?

It could be related to this bug where it’s not actlually lightdm, but some other program:

Thanks for the reply. No proprietary drivers are in use, this laptop only has integrated graphics. Everything reports one core as being 100% (htop, conky, system monitor, etc).

Currently as I type this I have nothing running on the laptop, it’s sitting idle at the desktop. Based on what you mentioned, I’ll try to see if any process is causing it but so far, nothing. And the logs for lightdm don’t show anything either.

Thanks again.

This is getting even stranger. It may not be anything to do with lightdm at all. I know how to reproduce this and cure this on command.

To solve it: Insert a flash drive
To reproduce it: Remove the flash drive

100% reproducible. I was about to install Ubuntu MATE so I inserted my flash drive, and I noticed as soon as I did, CPU usage went down to almost nothing. I removed the flash drive, and now CPU usage is high again.

Sorry to keep posting but I’ve found more info. It looks like it’s definitely not lightdm, so I changed the title of this thread.

It looks like I’m being bitten by the following bug:

I discovered that I do not have this issue with the Ubuntu 15.10 installation provided by System76. Before I switched to Ubuntu MATE, I took a Clonezilla image of the factory System76 install. I was unable to reproduce the problem there so far. So I am not sure at this point if System76 saw this problem and tweaked their image or if it was just happenstance that I wasn’t able to reproduce it in vanilla Ubuntu.


Check the kernel versions as you try different images. It may be possible it's a kernel bug that is causing these higher privileged processes to get stuck in some form of loophole.

uname -a

Linux crusader 4.2.0-25-generic #30-Ubuntu SMP Mon Jan 18 12:31:50 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

I tried installing kernel 4.3.3 from the mainline kernel repository, but with that kernel I get no X at all. I agree it may be a kernel issue so perhaps I need to try a different one.

Edit: I tried kernel 4.4 from that same repository, and I can boot properly and I don’t get the issue at all. So this definitely is something with the 4.2 kernel that comes with Ubuntu. I don’t consider this an solution, because I’d rather this be fixed in the real Ubuntu kernel rather than installing something from a PPA.

Edit 2: For anyone else that has this problem, do this (if 64-bit):
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-next/2016-01-11-wily/linux-headers-4.4.0-997-generic_4.4.0-997.201601102100_amd64.deb

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-next/2016-01-11-wily/linux-headers-4.4.0-997_4.4.0-997.201601102100_all.deb

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-next/2016-01-11-wily/linux-image-4.4.0-997-generic_4.4.0-997.201601102100_amd64.deb

sudo dpkg -i *.deb