16.04.2 Won't boot on RPi 3 Model B+

Same here. Apparently it’s because of the different processor. And I can’t run php7.1 or 7.2 on rapbian so this caused me to also downgrade my app to an older version of the framework :slight_smile: so even more work.

Same issue here. Boots to rainbow screen with low voltage indicator but I’m using the official supply which works fine with my model B. This post indicates this is not actually a power issue, it’s a boot code issue. Wish I’d just bought another model B instead!

1 Like

Same issue. I really hope the team could fix the problem.

Have the exact issue a user below mentions. Boots to rainbow screen and gets stuck, green LED never comes on.

I’m reporting the same issue - your not making it past the SD card valid check. Power LED is on , no activity reading from SD.

There is new hardware as well as the Full MKS GL video mode. What I’m disappointed in is no one seemed ready for this obvious change. Pi day every year new hardware, a new image is needed.

Help me Obi Wan your our only hope. Can anyone provide a time frame that isn’t months away?

Thank you

Same happens here!
I tested with latest Raspian Version and was able to install it.
This means the bootloader does not work with PI3B+

Hopefully Obi Wan is not our only hope. May the mate be with us! (<–Isn’t this a conflicting thing with my name?! mmmhh)

1 Like

You just need the latest bootloader/firmware files (and possibly the latest kernel). Not a big issue. See https://www.raspberrypi.org/forums/viewtopic.php?f=63&t=208538

Thanks. This worked for me, although I had to also copy over the updated firmware files in /lib/firmware/brcm.

Hi, Can you tell the where you downloaded updated firmware files? Thanks.

I installed Raspbian and then copied the files from that installation. I see that 18.04 is out now with a RPi download. I haven’t tried it but I would imagine that upgrading to that would also work.

1 Like

I installed Rasbian on another microSD card and the Raspbian was working ok. I then copied the /lib/firmware/brcm files to my hd and then transfered them to the other microSD which has Ubuntu Mate 16.04 to the same location. When I put the microSD into the pie and booted, it is stuck with the rainbow screen and the red led is blinking.

18.04 is only available for desktop ATM:

I will try copying the boot files from the raspbian to the ubuntu mate boot partition and see if that works. Also in another thread someone mentioned swapping the kernel with the raspian one. If I can’t get it to work, I will abandom this until they come up with a version that works and try ubuntu core in the mean time.

I created a Xubuntu installer that should work with the 3B+ AArch64 on Raspberry Pi 2 (rev 1.2), 3B, 3B+

@mannys5 if you intend to try snappy ubuntu core then have a look at the wiki page first https://wiki.ubuntu.com/ARM/RaspberryPi


@mannys5 yes you need to copy the kernel files across. I found that I needed the firmware files as well.

I too have the Pi 3B+ and have managed to run 16.04, but after so so much hard work and even then there were glitches such as no WiFi although it’s enabled. Really it’s not worth the bother until the ‘powers that be’ actually mod a version that will cope with the 64bit processor. Hope this helps

Disregard my post. i didn’t realize there was a new pi out and was referring to the pi i just received with the wrong name.

Pi3B+ was released in March 2018!


Disregard my post. i didn’t realize there was a new pi out and was referring to the pi i just received with the wrong name.

Feel free to check out the method I describe in “How-To Set Up and Upgrade Ubuntu MATE 16.04 on a Pi 2/3/3B+”. It will get you up and running 16.04 or 18.04 on a 3B+ :innocent:

1 Like

issue solved
Update kernel to version 4.14.37 and injoy :
use from this Link: https://www.raspberrypi.org/documentation/linux/kernel/updating.md