16.04 MATE Wifi connected after resume no wifi networks listed


Just wondering if this problem has been solved yet:

X220 Lenevo, latest BIOS, 16.04 MATE - Wireless card is Intel Centrino advanced-n 6205. Using Intel iwlwifi driver… All works well, WiFi works and shows connected Network AND all other networks in range.

EXCEPT, when laptop Suspend - then - Resume, previously connected WiFi network not shown, nor others in range (have not changed location). WiFi IS connected but shows the Ethernet connected icon in Network Manager.

Posted here: http://askubuntu.com/questions/762904/network-manager-ubuntu-16-04-wifi-connected-no-wifi-networks-listed

This I believe is the Bug, which I have subscribed to:


Just asking has ANYONE in the MATE world heard of a fix? This has been an issue for far too long for many 16.04 users…(just search for it to see what I mean)



This bug was changed to fix-released but a new one was open (refer to the last comments on 1574347)

New bug here: https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1589401

1 Like

Thanks ouroumov.

Yes that’s it. I have subscribed to both.

It’s a very frustrating bug!

The simple act of shutting the lid of your laptop computer, moving to another location, and NOT being able to see a list of WiFi networks to connect to is a right pain!



Also check yourself as affected using the green link at the top. (This bug affects XX people, does it affect you?)
It will augment the heat on the bug, drawing more eyes to it.

Thanks ouroumov.

Yes I have.

I hope they can get to this bug soon.

Thanks for your help.


I just upgraded from 14.04 to 16.04 and I have encountered this bug as well. My wifi worked great before the upgrade, but after a resume I lose my wifi connectivity and I need to restart the laptop. I agree that it is a pain! It is very frustrating.

I can report 16.04.1 and latest stable kernel and latest network manager 1.2.2 exhibits the same thing!

edit: That’s Kernel 4.6.3 & 1.2.2-0ubuntu6 Network Manager.

I wish this would get sorted!

Also some testing I did last week:

I tried 16.10 Yaketty Yak MATE Alpha 1 on the same machine.

Only tested for a couple of days but quite a few suspend-resume cycles. I can report that it worked fine! No issue with wi-fi networks not listed…

Sadly I had to ditch that version as it caused other problems/unstability on the machine.

Loaded 16.04.1 thinking that might fix things, but sadly it did not.

Same problem here. I’ve subscribed to the new bug, I’m hoping that it’s resolved soon.

In the meantime there is a workaround, which is to open a terminal and type:

sudo service network-manager restart

1 Like

I’ve been experiencing the same condition as others until one day I accidentally plugged in a second wifi adapter into my desktop before I unplugged the other one. I am approximately 50 feet from the router and through a kitchen and a bedroom with many obstacles. Even though the various ifterferences got through on windows 10 when I saw the screen change checked that the wifi was now working. if I only run one adapter it does not work but with two it works great. One adapter is an asus and the other is a netgear. I don’t understand it, but I hope this helps. It’s been working great for about a week, now.

Same problem with the Dell Precision M6400 and Ubuntu Mate 16.04.
Please programmers to provide because for years there is this bug. Available to help test.
I upgraded the system by following this guide http://www.webupd8.org/2016/06/install-mate-114-in-ubuntu-mate-1604.html, but the problem remains.

Running 16.10 now.

Still the same problem.

When is this going to be fixed?

Any idea’s anyone from here??



Just remove the battery and press the power button for 5 seconds. Reinstall wireless driver. - Start -> type Device Manager -> double click Network adapters -> right click and Uninstall (DO NOT DELETE) the wireless network adapter driver -> Restart the laptop.
If again the same issue occurs then proceed to Dell Precision M6400 Manual- guideusermanual.com/product-name-precision-m6400-manual&po=344511&lang=English for another fixes.

This is what worked for me:
Restart the network manager -
systemctl restart NetworkManager
Make sure wifi is not turned off -
rfkill list all
Show interfaces -
ls /sys/class/net
Pick out the wireless adapter device name, probably something like wlo1.
Bring it down-
ip link set dev <devicename> down
Release the DHCP-
dhcclient -r
Then bring it back up-
ip link set dev <devicename> up
Scan for networks.
iwlist <devicename> scan
Pick out the network you want, we’ll need the ESSID, Frequency and Address.
iwconfig <devicename> ap <access point mac address>
iwconfig <devicename> essid <ESSID>
iwconfig <devicename> freq <frequency>
dhclient <devicename>

Still a workaround, but if it works for you write this into a script once you have all the network info and just take a second to run it when you need it.

Ubuntu 16.04.2 LTS
Broadcom BCM4313 b/g/n Wireless Adapter

Also you might like -