16.04 on g4 mac mini, no sound

audio

#1

Hi
1 week ago I installed version 15 on my g4 mac mini, no particular problem, but audio won’t work
anyway yesterday I have upgraded on line to 16.04.
the audio proplem still is there.
googling around I have found it can be fixed opening the alsamixer app, but mine won’t start, neither from terminal, nor from its icon. (/usr/bin/alsamixer)
what could I do?
thanx
actually there’s another problem, but I will address it in another thd


#2

Hi @satiropan,

try installing the package “paman” which is the Pulse Audio Manager and try adjusting your sound with that!:

sudo apt-get install paman

https://wiki.debian.org/PulseAudio


#3

thanx for the answer
I did as you said, run paman and found (but I had already doubts):
in the server tab it says:
default sink auto_null
default source auto_null.monitor

and in the device tab it says
sinks auto_null output dummy

sources auto_null.monitor monitor of output dummy

so I think no audio drivers are installed
I am not expert in linux so I am not sure but these words ‘null’ and ‘dummy’ sound bad driver to me.
anyway in paman I have setted all the volumes to 75%, but no audio output anyway


#4

Let’s first double check that the kernel found no sound cards.
Post the output of:

cat /proc/asound/cards

Next, let’s see what the possible sound device could be.
Post the output of:

lspci -nn

For the G4 Mac mini it should be one of the Intrepid devices, probably the one that says “Mac I/O”.


#5

here is the terminal output for the 2 commands:

[email protected]:~$ cat /proc/asound/cards
— no soundcards —
[email protected]:~$ lspci -nn
0000:00:0b.0 Host bridge [0600]: Apple Inc. UniNorth 2 AGP [106b:0034]
0000:00:10.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] RV280 [Radeon 9200] [1002:5962] (rev 01)
0001:10:0b.0 Host bridge [0600]: Apple Inc. UniNorth 2 PCI [106b:0035]
0001:10:17.0 Unassigned class [ff00]: Apple Inc. KeyLargo/Intrepid Mac I/O [106b:003e]
0001:10:18.0 USB controller [0c03]: Apple Inc. KeyLargo/Intrepid USB [106b:003f]
0001:10:19.0 USB controller [0c03]: Apple Inc. KeyLargo/Intrepid USB [106b:003f]
0001:10:1a.0 USB controller [0c03]: Apple Inc. KeyLargo/Intrepid USB [106b:003f]
0001:10:1b.0 USB controller [0c03]: NEC Corporation OHCI USB Controller [1033:0035] (rev 43)
0001:10:1b.1 USB controller [0c03]: NEC Corporation OHCI USB Controller [1033:0035] (rev 43)
0001:10:1b.2 USB controller [0c03]: NEC Corporation uPD72010x USB 2.0 Controller [1033:00e0] (rev 04)
0002:20:0b.0 Host bridge [0600]: Apple Inc. UniNorth 2 Internal PCI [106b:0036]
0002:20:0d.0 Unassigned class [ff00]: Apple Inc. UniNorth/Intrepid ATA/100 [106b:003b]
0002:20:0e.0 FireWire (IEEE 1394) [0c00]: Apple Inc. UniNorth 2 FireWire [106b:0031] (rev 81)
0002:20:0f.0 Ethernet controller [0200]: Apple Inc. UniNorth 2 GMAC (Sun GEM) [106b:0032] (rev 80)
[email protected]:~$ ^C
[email protected]:~$


#6

OK. You should have “Snapper” sound system.

Compare and post the output of:

lsmod | grep snd

It should look like this:

[email protected]:~$ lsmod | grep snd
snd_usb_audio         151681  2
snd_usbmidi_lib        24883  1 snd_usb_audio
snd_hwdep               7010  1 snd_usb_audio
snd_powermac           65921  2
snd_pcm                98459  2 snd_usb_audio,snd_powermac
snd_seq_midi            6349  0
snd_seq_midi_event      6991  1 snd_seq_midi
snd_rawmidi            25199  2 snd_usbmidi_lib,snd_seq_midi
snd_seq                64013  2 snd_seq_midi_event,snd_seq_midi
snd_seq_device          5000  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              23723  2 snd_pcm,snd_seq
snd                    71471  17 snd_usb_audio,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_usbmidi_lib,snd_seq_device,snd_powermac
soundcore               7247  1 snd

Try this:

sudo modprobe snd-powermac

Then try the “lsmod” command above and “cat /proc/asound/cards” again.

If the modprobe works, then you need to edit /etc/modules and add the module “snd-powermac” to the list.


#7

this is the output of lsmod | grep snd

[email protected]:~$ lsmod | grep snd
snd_powermac           65921  0
snd_pcm                98459  1 snd_powermac
snd_seq_midi            6349  0
snd_seq_midi_event      6991  1 snd_seq_midi
snd_rawmidi            25199  1 snd_seq_midi
snd_seq                64013  2 snd_seq_midi_event,snd_seq_midi
snd_seq_device          5000  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              23723  2 snd_pcm,snd_seq
snd                    71471  6 snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_seq_device,snd_powermac
soundcore               7247  1 snd
[email protected]:~$ 

then I entered sudo modprobe snd-powermac but nothing happened.
then I reentered lsmod | grep snd but the output was the same.
then I opened etc/modules and this is the file:

 /etc/modules: kernel modules to load at boot time.

 This file contains the names of kernel modules that should be loaded
 at boot time, one per line. Lines beginning with "#" are ignored.

apm_emu
snd-powermac

so the snd-powermac line is already present.
what can I do?


#8

:sob:

Select Main Menu: System!Preferences!Hardware!Sound,
then select the Hardware tab.

Are any devices shown? If “PowerMAC Snapper” is there, make sure that “Analog Stereo Duplex” is selected. Sometimes the device is turned off.

It should be working. Unfortunately, I don’t have a G4 Mac Mini to test. There may be some subtle difference we are not aware of that is not taken care of in the Linux kernel.


#9

in System!Preferences!Hardware!Sound, hardware tab, there is no device :frowning:


#10

Try this:

sudo modprobe snd_aoa_codec_toonie

#11

Hello,
I’ve also came across this problem and no solution seemed to work. Here’s what I did to finally make the sound work:

Open the terminal and type sudo nano /etc/modules
Below all those paragraphs starting with a hashtag (#) type those 4 lines:
snd_aoa_i2sbus
snd_aoa_fabric_layout
snd_aoa_codec_tas
snd_aoa_codec_onyx

Click Ctrl+O, save changes and click Ctrl+X.

Reboot to get sure the changes were applied correctly. Now system should recognize your sound card.

If you still have no sound, install an app called QasMixer from Ubuntu Software Center and simply adjust the PCM volume control. That’s the easiest way, because this app comes with GUI.

That’s it, let me know if it worked for you.


#12

Also, I’m not sure if snd-powermac works anymore, so I would recommend you to erase all other lines in /etc/modules besides those four present in my advice.


#13

hi,
I upgrade from lubunu-14.04 to lubuntu-16.04.1
in my mac-mini ppc G4
I have same audio problem…

with cat /proc/asound/cards
I dont view any device

I try using /etc/modules

or

but I have same result

what can I do?

thanks

p.s.
in lubuntu-14.04 sound works OK


#14

[update]

I remove:
/etc/modprobe.d/blacklist.local.conf

now I view device:

but I dont hear any sound

p.s.
more info

from: paman
http://digilander.libero.it/sacarde/np/ppc3.jpg

from: sudo alsamixer
http://digilander.libero.it/sacarde/np/ppc2.jpg


#15

ohhhhh

I view the error !

by user root sound work OK
then, for normal user, not in groups: “audio” and “pulse”
so I add my user in that 2 groups

and all works

thanks a lot


#16

hello sacarde, I wanted to remove /etc/modprobe.d/blacklist.local.conf as you did but I can’t delete it, I am not expert, which is the way to delete it?
thanx


#17

SOLVED! I just did what you did, delete the /etc/modprobe.d/blacklist.local.conf wich ctually blacklisted only sound modules, nd udio is back, at list desktop sounds, I will test the whole stuff.
thanx nd regards

ps, tested all audio system and it works OK


#18

Worked for me :slight_smile: , in a iBook G4 with PlaySound (onboard).