16.04 will not install on my machine

I have an HP with AMD processor 16GB ram, etc. 16.04 boots up just fine. I launch ubiquity and when the first screen comes up I then hit the continue button. The window then closes. I have tried multiple times with two different disks. The disks pass the integrity test. They boot and run just fine; they just won't install. I can install it just fine in virtualbox. Any ideas?

So after you choose a language, the window closes without any form of error message?

At that point, the installer would:

  • Check available hard drive space.
  • Check for an Internet connection.
  • If there’s a battery, check if it’s plugged in.

I’d suggest unplugging all peripherals (except keyboard & mouse) and see if it continues.

Otherwise, boot to a live session, open the terminal and execute ubiquity (then press tab to autocomplete, I’m not sure if it’s ubiquity-installer or something). When it crashes, there will be error details from the terminal which can be reported using apport.

I don’t have any peripherals plugged in to the computer. I also used the command line to run ubiquity hoping to see what was going on. Ubiquity exits and returns to the command line. No verbage whatsoever about errors or anything. 15.10 installs just fine. Also, this build is different with regards to booting. I’m unable to use unetbootin to create a usb stick. I had to burn a DVD. Not the usual menu that comes up at boot. Don’t know if this is just for testing or if that will be the way it is done from now on. Any other ideas for how to capture errors?

Hmm, the boot menu shouldn’t be too different, it’s just like all previous versions with a grey background and the usual 5 options with the UM Logo at the top. If it’s completely different to that, have you got a screenshot?

Next time, try writing the ISO image to a USB stick using GNOME Disks, I find that to be the most reliable. We could be dealing with a faulty ISO/DVD.

I’m not at my computer to check, but is there any verbose flag or hints where the log could be?

ubiquity --help

We’ll be sure to find the log somewhere, I don’t really know for sure, but as a last resort, search for all traces:

grep -r 'ubiquity' /var/log/

Here is my boot screen:

Have not seen this before the Alpha.

Thanks for the tip of using Gnome Disks to create a usb stick. I like it better than unetbootin.

I put a picture on the forum of my boot screen. I was not allowed to post
the ubiquity errors so I have attached them here. I don’t know how to
interpret them.

It looks like you attached the logs as an e-mail reply, which isn’t something the forum (Discouse) processed. :mailbox_closed: Since you’re still a new member, copy the text to http://pastebin.com/ and leave a link here.

That boot screen is the text-based version, which shouldn’t happen - It could be down to a corrupt download or the fact the DVD that wasn’t burnt properly (the disc type can play a role too). To confirm, does this text-based boot menu appear in your VirtualBox tests?

Try verifying the ISO:

md5sum /path/to/xenial-desktop-amd64.iso

It should output this (for amd64), if not, it’s a bad copy:

772a8dc29143d9d57933faf65d6fda4f xenial-desktop-amd64.iso

(Others for UM 16.04 Alpha 1 can be checked here)

I ran md5sum /home/rick/Downloads/xenial-desktop-amd64.iso

My output was 093395640aec16b8e0b1168ea6a23e87

Is this a good copy for amd64?

No, unfortunately your copy is corrupt since your hash doesn’t match the actual hash. :disappointed:

A checksum (MD5 being one algorithm) reads the file in full and produces a hash, it’s a common way to check file integrity. Different hash = Corrupt image = Strange things happen.

Downloading via HTTP is more likely to encounter a bad image, it’s one reason why torrents are a recommended choice, as data is checksummed as it downloads.

1 Like

Here is the link: http://pastebin.com/Wb9uHTtQ

I compared the sh256sum to the download and it is good. I burned to two
different disks with brasero and they both verified. I created two
different usb sticks with Gnome disks. What is interesting is that it
boots differently in virtualbox. I don’t get a menu at all. It boots up
into the welcome screen where you go on up to live or proceed with the
install. On the virtualbox install it does not come up to the language
screen. It comes up to screen where it checks drive space and internet

Yes, thank you. Here is the error message when I tried to run this copy in VirtualBox.

Failed to open a session for the virtual machine Ubuntu MATE 16.04.

VT-x is disabled in the BIOS for both all CPU modes (VERR_VMX_MSR_ALL_VMX_DISABLED).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

@RickLell In your case, it’s a configuration problem with the BIOS and/or the virtual machine’s settings. It looks like Hardware Acceleration is turned off (or not supported on your computer). Try enabling PAE/NX in your virtual machine’s settings and check VT-X (Virtualization Technology) is definitely enabled in the BIOS.

This error hasn’t got anything to do with the ISO image.

@jallain It sounds like the graphical menu is working, you need to press space bar when you see a grey screen with an “accessibility” icon at the middle bottom. Ignoring this takes you to the selection screen to either “Try” or “Install” as you described.

From the log, problems start at around line 103, it’s something to do with ureadahead:

ureadahead[1255]: ureadahead:/usr/share/ubiquity/start-ubiquity-dm: Error retrieving chunk extents: Operation not supported

Followed by a lot of similar messages and then the graphical front end (GTK) crashes completely.

Interestingly, near the bottom I see this line:

/var/log/syslog:Jan 6 16:44:19 ubuntu-mate ubiquity[6324]: return (int(secureboot) == 1)
/var/log/syslog:Jan 6 16:44:19 ubuntu-mate ubiquity[6324]: ValueError: invalid literal for int() with base 10: ''

Which is telling me that Ubiquity is unable to determine whether your system has Secure Boot enabled or not. Are you using a UEFI-based machine? Which OS is already installed on the machine?

Try tweaking some settings in the BIOS, such as booting in “Legacy” mode to see if things are any different.

I can only point and observe, we can continue that in this thread, but the best way to get this problem seen is to report this bug to Launchpad against ubiquity and hope it gets seen.

1 Like

For anyone else reading this thread, make sure you burn your disks at the slowest possible speed to avoid input/output write errors on the disk!. :smiley:


Thanks for all your help. I have had my machine set up for legacy booting ever since I’ve had it. It is just really strange that 16.04 boots just fine in a vm but not my real machine. I will take your advice and file the bug reports. Again, thanks for all your help.

1 Like

One final observation on my case. I booted up after ensuring that my machine is definitely set up for legacy booting and NOT UEFI. I finally go the installer to run by running ubiquity --automatic. The installer does not quit and eventually gets to a screen that tells me: This machine’s firmware has started the installer in UEFI mode but it looks like there may be existing operating systems already installed using “BIOS compatibility mode”. If you continue to install Debian in UEFI mode, it might be difficult to reboot the machine into any BIOS-mode operating systems later.

If you wish to install in UEFI mode and don’t care about keeping the ability to boot one of the existing systems, you have the option to force that here. If you wish to keep the option to boot an existing operating system, you should choose NOT to force UEFI installation here.

At this point I exit because I don’t want to ruin my configuration. Apparently I can’t get 16.04 to boot up in legacy mode. Interesting…

It appears that you are booting the 16.04 image in UEFI mode. I experienced this when doing some ISO testing on the 16.04 alpha. It appears that you have an OS on the machine which boots non-UEFI so in order not to hose it up…

When you first boot the 16.04 image you should see an chance to access boot options (at the machine level - before the OS). On my Dell computers it is accessed by hitting F12. Once you get to that screen make sure you are booting the 16.04 image in Legacy (non-UEFI) mode and you should be good to go. My UEFI enabled machine shows a listing for the USB flash drive or DVD in both Legacy and UEFI.


1 Like