17.04 Can't switch tty's with ctrl+alt+F(x)

Hi, in Ubuntu Mate 17.04 64 bit I can’t switch to other tty’s.
Pressing ctrl + alt + F(x) keys hides the mouse pointer. ctrl + alt + F7 brings it back.
I’m using i915 graphics on a thinkpad.
I tried with the property intel driver and without but nothing changed.

[quote=“Holgerrpl, post:1, topic:13043”]Pressing ctrl + alt + F(x) keys hides the mouse pointer.[/quote]After the pointer has gone, can you still interact with the desktop environment? Because I’m actually thinking you actually ARE in a TTY, you’re just not seeing it.

So, to try, open a few applications (so we have something that’ll respond to keyboard input), switch to a TTY and see if you can alt-tab between the applications. If not, we’re looking at an invisible TTY. :wink:

Yes, you are right. The tty is working, but the display does not change.
I pressed ctrl + alt + f1. I still saw my browser. I signed on blind and tried sudo reboot also bind.
And it works well. :grinning:
Nice to know, but for the future a little uncomfortable.
sudo chvt 1 has the same effect. So the tty’s are working. I looked at the log and lightdm log also, but there is nothing unusual to find.

[quote=“Holgerrpl, post:3, topic:13043”]The tty is working, but the display does not change.[/quote]It does give you something very specific to Google for. You can’t be the first to experience this sort of behaviour.

What are you actually trying to achieve?

Why do you want to switch to another TTY?

Do you want to start a second display server?

I can't reproduce this on my 17.04 install.

[quote=“Holgerrpl, post:3, topic:13043”]but for the future a little uncomfortable.[/quote]Probably not going to do much but could you try the various window managers in Control Center > MATE Tweak > Windows.

In particular, try disabling any and all compositors. Including going to Control Center > Windows > untick Enable software compositing window manager.

Hi @Holgerrpl. Not running a Thinkpad but want to mention one thing I learned about the TTY console modes and how they tie directly into the terminal mode grub sets up for itself. Things like grub displaying vs not displaying making a difference and settings in /etc/default/grub for grub graphics also setting the tty resolution.

It got me flustered trying to get a decent TTY resolution while grub was in text mode. It's something you might test:

It wouldn't surprise me if TTYs started working.

[quote=“Bill_MI, post:8, topic:13043”]grub graphics also setting the tty resolution[/quote]That confirms a hell of a lot, actually. I always wondered why sometimes my TTYs appear graphic-ish and sometimes they don’t. Now I know, it’s related to my grub tinkering.

What I've tried until now:
Changing window managers with mate tweak -> nothing changed

I downloaded Xubuntu 17.04 and installed it on an usd drive. There it does not work either. So it's not a Mate only issue.

I have on the same laptop a partition with linux mint 18.1 Cinnamon with the same kernel as Ubuntu Mate 17.04. There the switching between tty's works.

Ubuntu Mate is using a newer intel microcode. So I downgraded to the mint version. -> nothing changed

I thought perhaps it could be lightdm. I changed to xdm. It was not lightdm. -> nothing changed

Than I use grub with kernel option nomodeset. It's the same like i915.modeset=0.
That works, but I got errors from intel ips.

After blacklisting intel ips in modprobe.d it looks a little better.

But this is with the kernel option nomodeset. So I have not the chance to change the display resolution and the external monitor is not recognized.

Linux Mint is based on 16.04. The desktop environment seems not to matter. The kernel and the intel microcode are the same. Something in this case must changed in Ubuntu between 16.04 and 17.04, but nor the kernel or the intel microcode should be the problem.

[quote="Holgerrpl, post:10, topic:13043"]Than I use grub with kernel option nomodeset.[/quote]No need for that.

So it reads:
sudo update-grub

And reboot.

Given what was said in:

I am actually of the opinion that TTYs use the graphic/console settings of grub. So, forcing grub into a console mode should force the TTYs into a console mode as well? Not sure, it is worth a shot however.

Thank you all,
but the only effect of GRUB_TERMINAL=console is that the screen resolution of the grub menu is lower.
It has no effect when I am in X. The same issue of the “blind tty”.
When I got a little more time I will take a look at the xserver.

Update. The problem exists only when the laptop is in the dock. Undocked and without a second screen the ttys are working like expected. I think it must be the xserver.

[quote=“Holgerrpl, post:13, topic:13043”]Undocked and without a second screen the ttys are working like expected.[/quote]Aren’t they simply being rendered to the second screen then?

Edit: What I mean is, could that be what’s actually going on? The TTYs being displayed somewhere else?

What is a tty ?



A “tty” is a ‘TeleTYpe’ or printing terminal, but also a pseudo-device used to display text in a similar way on a computer screen: A so-called ‘glass’ teletype or probably LCD now :slight_smile:

The main point is that it’s a text-only display.



I got the solution.
When the laptop is in the dock the xserver doesn't recognize the graphic adapter and turns to vesa mode.
The solution is simple: Create an xorg.conf and it works.
It's a little bit like in the 90's when I bought my first Suse 5.2 Distro with a book in a bookstore and wrote my own xserver-configuration to get a graphical desktop. :slight_smile:

I wrote this little xorg.conf and copied it to /usr/lib/X11

Section "Device"
Identifier "Intel Graphics"
Driver "intel"
Option "AccelMethod" "sna"
Option "TearFree" "true"

After restart the switching between the tty's works like it should.
I compared the Xorg.0.log before and after adding xorg.conf with Meld, so you can exactly see what was going on.

1 Like

[quote=“Holgerrpl, post:17, topic:13043”]When the laptop is in the dock the xserver doesn’t recognize the graphic adapter and turns to vesa mode.[/quote]That might be something worth reporting as a bug.

And, nice investigative work. Mark it as a solution so others will see it more easily.


thanks for the explanation.

The solution above works here. I have the same problem and I’m very happy with your solution.