[17.04] Nm-applet works fine but shows 2 icons in the system tray

nm-applet works fine but shows 2 icons in the system tray. One is a bit smaller than the other but right-clicking both bring up functioning menus.

I am running 17.04.

That was also true for my notification area in 17.04 beta so I removed the nm notification applet. I tried adding it back but no apparent luck in doing that. The dconf editor was also no help in removing the added panel objects (that did not display). I left well enough alone and booted back into 16.04.

If you have the same problem again, the easiest way to fix it is by choosing a different panel layout in MATE Tweak and choosing the one you want to again.

Thanks elcste, I did that before I closed out my session. Dconf reflected the change. I’ll spend a bit of time next session restoring the launchers.

elcste’s suggestion works temporarily, but when I reboot both wifi icons are back regardless of which panel layout I choose.

I confirm this behavior. Upon reading randomdave’s post, I rebooted into 17.04 beta and there were two wireless network icons present.

The larger one behaved as my 16.04 network icon does - either right click or left click shows the available networks. The smaller one on the right shows that information only when right clicked.

Bug or feature?

I wasn't clear … my suggestion was only to fix a panel layout that got messed up from experimentation, not to solve the main issue in this thread.

I also am seeing the two network icons in 17.04, I think only since MATE 1.18 landed. The MATE Desktop changelog for 1.18 lists some panel improvements, including

Added StatusNotifier support.

I wonder if the panel is now picking up nm-applet via two different interfaces: however it did before plus this newly supported one?

Yes I have experience that problem too
I tried many way still can’t fix

It disappeared for me, not sure what actually made it disappear but here is what I recall doing (CLEAN INSTALL):

apt update
apt upgrade
reboot

Remove bottom panel
Moved top panel to bottom
Changed theme to Submarine Green
Changed Icons to MATE-Faenza-Dark
Add windows lists to the now bottom panel
Swapped Main Menu with advanced mate menu
Increased bottom panel too 36px

I think that’s all I did and was no longer there :slight_smile:

antechdesigns: Did your method survive a reboot? For me, increasing the panel size to 36 then logging out and back in removed the second wifi icon but its back after reboot.

Yes It did, I remember keeping my eye on it as I was installing software, drivers, compiz, etc

However this was in a virtual machine which I no longer have setup

Also I used the daily build version which I got from here: http://cdimage.ubuntu.com/ubuntu-mate/daily-live/current/

http://cdimage.ubuntu.com/ubuntu-mate/daily-live/current/zesty-desktop-amd64.iso

Bare in mind, these are daily builds so the one I used may not be the one that is there now.

EDIT
Just downloaded and installed the latest daily build from the link above and it looks like its fixed at least in the virtualBox :grinning:

However I noticed the welcome screen not showing its contents, just a white background with a cursor top left :rage:

[Welcome] DPI below 50. Out of range..

OMG I thought i was tripping for a minute there, I saw 2 of my wallpapers in there :sunglasses:

I just tried the latest beta2 17.04 release. The same issue with the double network connection icons is there too

I can’t reproduce it in Ubuntu 17.04, but that might be related to the fact it’s in a VM. I can reproduce it on baremetal with another system, it’s Mint 18.1 (based on Ubuntu 16.04) where I have all the latest MATE 1.18 packages built and installed locally.

I see this issue right after booting the system with autologin enabled, or after bringing it back from suspend. Logging out and then back in to start a new session doesn’t trigger this. This might be some kind of race condition. Might be something in nm-applet which is only triggered by our new StatusNotifier support in the notification area.

The simplest method to make it go away is to restart the panel (killall mate-panel). Of course this is only for the current MATE session.

I hope to find the real cause of this, because it’s one of those little things that can be quite annoying… :slight_smile:

I can see this issue on my Ubuntu 16.04 machine. It was ordinary distribution with Unity, then I’ve installed mate-desktop 1.18. Can see it every time after I login, entering password. Restarting the panel (as suggested by @monsta ) helps only for several minutes, then this issue is back again.

Just tested it on baremetal in Debian Testing (with MATE 1.18 built and installed locally). It’s not reproducible with any method I mentioned before. For the record, nm-applet is 1.4.4 there, while Ubuntu 17.04 has 1.4.2 and 16.04 has 1.2.6.

I’ve seen it on bare metal, but I have not updates in a day or so. I can check it again tomorrow (it’s at work).

One thing I noticed is the “keys” icon that appears when you enter the admin password (like when installing software updates that require a password) appears between the two NM icons. The functional icon is the one on the left of the keys icon, and the one on the right only responds to right click.

I don’t know too much about this, but could the the second icon be because MATE Panel now has StatusNotifier support? I think NM can be configured to display an icon in a few ways (applet, indicator), and maybe the second icon is using a method that didn’t use to work with MATE panel so it didn’t show up?

I have two (2) Network manager icons in the system tray. Anyone know how to get rid of one of them?
It’s not a drastic problem just a little annoyance. networking is working fine.

I've seen the same thing in my 17.04 VM.

what's the output for:

ps axu | grep [n]m-applet

Best guess is, two instances of the applet are running at the same time.

Here’s the output of ps axu | grep [n]m-applet
2231 0.2 1.0 756896 37184 ? Sl 06:01 0:03 nm-applet
and I only see one instance in Processes list.

OK, it's weird, and I can confirm I've got the same thing in my VM:

It seems the icon on the right is "dead", nothing happens when I click on it.