[18.04] Can't get Ibus or Fcitx to work

software

#1

I want to use ibus-unikey or fcitx-unikey to type Vietnamese
I have set up the input method, etc... and reboot several times but neither ibus nor fcitx work.

The keyboard shortcut for scrolling between input method doesn't work neither.
Any work-around guys? Thanks in advance!


#2

Is your problem fixed ?
I have some tips for you. Choose only 1 language (english) for System Keyboard Layouts, configure iBus and let it uses system keyboard layout


#3

Hope your issue got fixed. Here is what helped me.
Make sure to install the following pakages

ibus-m17n
ibus-table-extraphrase
ibus-gtk
ibus-gtk3
ibus-qt4
ibus-table
ibus-clutter

Choose the input method switch and make ibus as the choice.
A dialalogue box to restart X session appears choose ok.
Log out and login back to restart X session.
Go to ibus system tray icon choose preferences
click input method tab and your language option
choose them to the add to list .---done---
For more info refer here.


Hope this works for your language too