18.04 Double Clicking Menu Bar Doesn't Maximize

I selected the behavior to Maximize, but it doesn’t work. Also double clicking a word doesn’t select it. I’ve tried both Marco and Compiz.

Hi Mikey,

what desktop layout are you using?, it works fine for me using “Traditional”!.

What are your software settings like?:


1 Like

I’m using Familiar because I want the hud and brisk menu. My settings
are very basic. The horizontal and vertical maximize settings work when
I turn them on but standard maximize doesn’t. And as I said, I tried
switching my window manager. That did nothing. I installed from cd
after downloading and burning the iso. I wanted the install to be very
clean; so I didn’t upgrade. I reformatted my disk. Then I went through
the getting started steps. I have a big 75" monitor; so I have Hdpi on
and have set my dots=per-inch to 200. Other than that, I installed the
nvidia drivers. I have two monitors. My second is a 50". Everything
else seems to work. You’ve all done a great job, as always. :slight_smile:

I tried switching to traditional and a few others. It didn’t change.
BTW, my gpu is a geforce 760.

What drivers are you using for the Nvidia GPU?. :smiley:

Thank you so much for your help. I’m using the nvidia-driver-390.
Here’s some system detail:

System: Host: smaug Kernel: 4.15.0-20-generic x86_64 bits: 64 gcc: 7.3.0
Desktop: MATE 1.20.1 (Gtk 3.22.30-1ubuntu1) info: mate-panel
dm: lightdm
Distro: Ubuntu 18.04 LTS
Machine: Device: desktop System: ASUSTeK product: K30AD_M31AD_M51AD
serial: N/A
Mobo: ASUSTeK model: K30AD_M31AD_M51AD_M32AD v: Rev X.0x
serial: N/A
BIOS: American Megatrends v: 0802 date: 08/03/2015
Battery hidpp__0: charge: N/A condition: NA/NA Wh volts: NA
model: Logitech Wireless Touch Keyboard K400 serial:
status: Discharging
CPU: Quad core Intel Core i7-4790 (-MT-MCP-) arch: Haswell rev.3
cache: 8192 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips:
clock speeds: min/max: 800/4000 MHz 1: 3736 MHz 2: 3785 MHz
3: 3809 MHz 4: 3786 MHz
5: 3751 MHz 6: 3766 MHz 7: 3760 MHz 8: 3777 MHz
Memory: Using dmidecode: root required for dmidecode
Graphics: Card: NVIDIA GK104 [GeForce GTX 760 OEM] bus-ID: 01:00.0
chip-ID: 10de:118e
Display Server: x11 (X.Org 1.19.6 )
drivers: nvidia (unloaded: modesetting,fbdev,vesa,nouveau)
Resolution: [email protected], [email protected]
OpenGL: renderer: GeForce GTX 760 (192-bit)/PCIe/SSE2
version: 4.6.0 NVIDIA 390.48 Direct Render: Yes
Audio: Card-1 Intel 8 Series/C220 Series High Def. Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:8c20
Card-2 NVIDIA GK104 HDMI Audio Controller
driver: snd_hda_intel bus-ID: 01:00.1 chip-ID: 10de:0e0a
Card-3 Asahi Kasei Microsystems AK5370 I/F A/D Converter
driver: USB Audio usb-ID: 003-002 chip-ID: 0556:0001
Card-4 Logitech driver: USB Audio usb-ID: 003-005 chip-ID:
Card-5 Harman driver: USB Audio usb-ID: 003-004 chip-ID:
Sound: Advanced Linux Sound Architecture v: k4.15.0-20-generic
Network: Card-1: Intel Ethernet Connection I217-V
driver: e1000e v: 3.2.6-k port: f040 bus-ID: 00:19.0
chip-ID: 8086:153b
IF: eno1 state: up speed: 1000 Mbps duplex: full mac:
Card-2: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter
driver: rtl8821ae port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8821
IF: wlp3s0 state: down mac:
Drives: HDD Total Size: 3250.7GB (0.5% used)
ID-1: /dev/sda model: Samsung_SSD_850 size: 250.1GB serial:

ID-2: /dev/sdb model: TOSHIBA_DT01ACA3 size: 3000.6GB
Optical-1: /dev/sr0 model: ATAPI BD E DH12E3SH rev: MAA3
dev-links: cdrom,cdrw,dvd,dvdrw
Features: speed: 48x multisession: yes
audio: yes dvd: yes rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
Partition: ID-1: / size: 229G used: 15G (7%) fs: ext4 dev: /dev/sda1
label: N/A uuid: ba1d3393-d3a0-4f63-970f-a671363cf0c1
RAID: System: supported: N/A
No RAID devices: /proc/mdstat, md_mod kernel module present
Unused Devices: none
Sensors: System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 0.0:64C
Fan Speeds (in rpm): cpu: 0
Info: Processes: 289 Uptime: 3:58 Memory: 6358.7/15980.8MB
Init: systemd v: 237 runlevel: 5 Gcc sys: 7.3.0 Client:
Unknown : systemd inxi: 2.3.56

I tried switching from the 390 metapackage driver to the 340 binary, but
my system won’t let me. So my choices are either the nouveau driver,
which I don’t want, or the 390 metapackage driver, which is what’s


My system seems completely hosed now. Trying to switch to the binary
nvidia 340 driver has caused a package mismatch. I will try to switch
drivers again. If that doesn’t work, I’ll try to remove both nvidia

I reformatted my disk and reinstalled. I must say BB is absolutely beautiful and worth any trouble I’m having. Hdpi is amazing! Anyway, this time, as soon as the Welcome window first opened, I tried to maximize it by double clicking the menu bar, and nothing happened. So we know it’s not a settings issue, because nothing had been set yet. I hope this helps. BTW, I think I figured out that my system got hosed. It was because I didn’t press “revert” first before trying to switch to the binary nvidia driver. It was totally my fault, but I can see how this could happen often. If one needs to revert back to the nouveau driver first before switching to a different proprietary driver, shouldn’t that be automated? Anyway, I can live without double click working for now, if you have bigger fish to fry. Cheers!

I should mention that I’m using a logitech k400r keyboard with a touchpad. I suspect that this problem is related to the touchpad.

Here’s a suggestion I found for 17.04. Does it make sense to try this? sudo apt install xserver-xorg-input-synaptics

It is definitely the Logitech touchpad. If I double-click the buttons at normal speed, the k400r has buttons, too, it works. If I double-touch the touchpad very, very slowly, it also works. So there is something going wrong with the touchpad settings. They are different somehow from mouse settings.

I found this post which seems to get to the heart of the matter: https://bbs.archlinux.org/viewtopic.php?id=232664

Hi Mikey,

try adjusting the speed of the touchpad, that may help?, I am not on my laptop at the mo but you get the idea?:


1 Like

Thank you. It helps a bit, but there is something wrong with the driver. I can use my buttons to double-click for now. BTW, Chrome looks sweet when I set the title bar to use the system title bar and borders then set the Google Chrome theme to GTK+. :wink: And I can finally see my system tray at a good size with Hdpi set to on. I wonder, however, that auto Hdpi doesn’t do the same thing. Cheers!

Try running the following command, there may be missing dependencies?:

sudo apt update && sudo apt dist-upgrade -f

Thank you very much. Everything seems okay: upgraded, 0 newly
installed, 0 to remove and 0 not upgraded. I read that the Logitech
k400r is an older piece of tech; so newer libraries may spend less
effort om it. I just don’t know what keyboard, trackpad combo would be
better. Is there a preferred hardware list? I can lose the keyboard.
I’m not parting with Bionic Beaver, however. :wink:

Hi Mikey,

do you have your software sources download location set to “Main server”?, if you have a local server, you may not have all the latest packages just yet if they haven’t been synced yet?. See the update guide in post # 2 above if you don’t know how to do that!. :smiley:

I’ve just switched from Server for the United States to Main Server. Then I’ve run the software updater. It’s come back as up-to-date. The double-click is still very slow, but thank you so much for helping me.

1 Like

I found this but I am not sure if it will help you at all?:


1 Like