18.04 Install, not detecting bluetooth

I installed 18.04 on a computer with an Asus Maximus X Hero-Wifi motherboard, which uses the Realtek 8822BE driver to control wifi and bluetooth that its integrated there. From what I found googling support for this driver was added in kernel 4.14, and 18.04 having 4.15 it should be fine then. However, only wifi works, when I click the Bluetooth Adapters options it says that we need to enable it first. After enabling it, I get a tiny window with only the close button appearing.

What can I do to make bluetooth work?

1 Like

Hi @Cold,

start here:

https://wiki.ubuntu.com/Bluetooth :smiley:

Hey @wolfman :slight_smile:

Checked that page, but didnt find anything relevant to my case.

Tried to see if it was blocked with rfkill, and nope:

sudo rfkill list
[sudo] password for azul: 
0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

Tried to see with systemctl the status:

systemctl status bluetooth.service
â—Ź bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
   Active: active (running) since Thu 2018-04-12 07:32:07 AST; 1h 13min ago
     Docs: man:bluetoothd(8)
 Main PID: 960 (bluetoothd)
   Status: "Running"
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/bluetooth.service
           └─960 /usr/lib/bluetooth/bluetoothd

Apr 12 07:32:07 azul-System-Product-Name systemd[1]: Starting Bluetooth service...
Apr 12 07:32:07 azul-System-Product-Name bluetoothd[960]: Bluetooth daemon 5.48
Apr 12 07:32:07 azul-System-Product-Name bluetoothd[960]: Starting SDP server
Apr 12 07:32:07 azul-System-Product-Name bluetoothd[960]: Bluetooth management interface 1.14 initialized
Apr 12 07:32:07 azul-System-Product-Name systemd[1]: Started Bluetooth service.

So from what I understand, it seems to shows that its running, but when I want to add devices it says that there are no adapters.

Tried with bluetoothctl

bluetooth]# power on
No default controller available
[bluetooth]# discoverable on
No default controller available

Yeah dont know what else to do.

Hi Cold,

I don’t have any BT devices to try out so really cannot help you any further; sorry!. :frowning:

Have you also tried it with “Blueman”?. See the following link which may help you out?:

https://www.maketecheasier.com/setup-bluetooth-in-linux/ :smiley:

Sadly, that didnt work.

Any place I can report the misbehaving driver/missing driver functionality?

Hi Cold,

are there any settings on the laptop you are missing?:

https://www.asus.com/us/Motherboards/ROG-MAXIMUS-X-HERO-WI-FI-AC/HelpDesk_Manual/ :smiley:

Its a custom built desktop computer, not a laptop.

Checked on the motherboard settings, Bluetooth Controller is Enabled. Also gave it a try on a Windows SSD, and the bluetooth there works.

I typed “laptop” by mistake, as you can see from the link I posted above, it is for a normal PC mobo!. That said, I really have no idea as Bluetooth is fully working on my laptop but I don’t use it so cannot really help you further!. :frowning:

@Cold, have you tried disabling Wi-Fi in the BIOS and/or in your OS to see if Bluetooth will work while Wi-Fi’s disabled? That’s not a fix if you don’t have a wired connection for your desktop, but if you just need Bluetooth capability, it’s a workaround if successful. It certainly sounds like a driver issue. I saw the article about driver support coming for kernel 4.14 too, but it’s a combo device and early days still, so support may come. I’d have trouble giving up the fight myself, but you could get an inexpensive Bluetooth dongle to use if you have to have Bluetooth until the device is better supported.

Hello, just tried to disable the network controller on the motherboard, but it still didn’t work.

And yeah, I use bluetooth for my headphones or controllers, so its kind of a bummer it isn’t working. Need to check what dongle supports the gamepads until support gets better.

If you could figure out which package to file it for, filing a bug report on launchpad would be the next step, I guess. Maybe someone here (@wolfman ?) could point you at the correct package?

Hi Cold,

try checking the hardware support list, you might find your device on it or not?:

https://certification.ubuntu.com/desktop/ :smiley:

1 Like

A lot of people (including myself) are not informed when they buy a computer
Sellers point out RAM Gb and HDD Tb and BIG SCREEN
and hide info about compatibility because cheap compnonents are inside

Next time I will buy a Linux pre-installed computer, usually with Ubuntu
and for sure swap it with MATE

Hi Vladimir,

that would make sense if you know in advance that you are only going to use Linux (Ubuntu Mate). :smiley: All the hardware would (should) work OTB. :thumbsup:

Well, the operating system is operating system.
Linux is enough capable to satisfy my needs.
I am not interested to pay Microsoft’s newest OS bundled with a “peek-a-boo” technology.
And this little netbook will be kept for the playing old games that cannot runs under the Wine. Somewhere I have a saved partition with the XP with all updates till the support ends.

Living with Linux desktop?
Why not

And I’ve noticed the computers that can support Linux (because of included hardware) are bit more expensive than those dedicated for the one commercial system only.

So an update here:

Used a friend launchpad account to report the missing feature.

So I found that in kernel version 4.17rc6 it finally detects the motherboard’s bluetooth adapter, was asked to bisect the kernel now. If anyone here ever did that, any tips would be appreciated.

Also tried a bluetooth headphones, ps3 controller and my phone on Ubuntu 16.04 and Ubuntu-Mate 18.04 with varying results:

  • Headphones were detected and worked on Ubuntu 16.04, on Mate 18.04 it connected but cant pair. So cant hear anything on it or appears on the sound menu.

  • PS3 controller connected on Ubuntu 16.04, but it also controlled the mouse. Mate 18 didn’t have this problem, but it doesn’t directly connects to the pc, so I need to fiddle with bluetooth settings (also get the connected, but couldn’t pair message).

  • Phone worked ok on both. Could send and receive files no problems.

Why cant I get the bluetooth headphone to work on mate 18.04 or automatically detect the ps3 controller when I turn it on? Is the bluetooth program on Ubuntu 16.04 that different than Blueman?

Hi Cold,

the following may help?:

https://support.system76.com/articles/bluetooth/ :smiley:

https://wiki.archlinux.org/index.php/bluetooth :smiley:

Did you finally get this sorted? I had the same issue on a fresh install of Ubuntu 18.04. I updated bluez, restarted and the and the problem went away.

See this https://medium.com/@overcode/fixing-bluetooth-in-ubuntu-pop-os-18-04-d4b8dbf7ddd6

Yeah, I fixed it by updating the kernel. If you enable Ubuntu hardware enablement stack (HWE) you should get some new hardware compatibility:

 sudo apt-get install --install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04

Think more recent versions of the kernel had an even better driver support, but I'm ok with it for now.

Thanks for the help, might check what version of bluez I have and update.

1 Like

Thanks man, Cold your technique worked like a magic, was onto this for the last 2 hours. Updating the kernel worked for me