[19.04] VLC randomly hangs on quit


#1

Hello,
Since upgrading from 18.10 to 19.04, I've noticed an annoying issue with VLC: when closing it, it sometimes hangs, its process still running and I can't play another video until I manually kill it. If I have its panel icon enabled, when that happens, I have the option to show its window from the menu, and it's completely blank. Note that if I try to quit from the menu, it doesn't work, the only way is really to kill the process (which isn't defunct, BTW). Running it from the terminal doesn't show anything special when I quit and it hangs (though ctrl + C there kills it).

I've tried to delete its config files just in case but no change. I've tried the latest daily build from the devs PPA (4.x branch) and get the same behaviour with it, so I suspect that the issue lies somewhere in MATE rather than VLC itself (just a guess). Unless it's a bug introduced in 3.0.5 or 3.0.6 and also there in 4.x.

Anybody noticed the same behaviour?


#2

No, it's in VLC. I had that with an Antergos box I was playing with a while back and is known to occur with Intel video chipsets. When I dropped a Nvidia card in, the problem went away.

A work-round is to make sure you stop the video before closing VLC's window.


#3

Oh, ok, thanks. I don't have an Intel GPU but an AMD one, it might be an issue with Mesa, maybe? Do you have more information about the issue, like a bug report on VLC's website?


#4

May be a new, but similar bug, then. IIRC, the bug was on VLC's bug tracker, but as it was a while ago, I lost track of it. Sorry.