[19.10] How to extract WAV off a DVD?

Hello Community,

I have been fighting for well over 1 hour trying to get transcode to work and it's dying at:

checking if linker needs -framework vecLib... 
checking for pkg-config... no
checking for pkg-config... no
checking for X... no
configure: WARNING: can not find X11
checking for gzopen in -lz... no
configure: error: transcode depends on libz, but cannot links against libz
make: *** [Makefile:411: config.status] Error 1

And on another (debian) system I got a couple of steps further but still no luck:

make[2]: Entering directory '/home/t/bin/transcode-1.1.7/encode'
make[2]: Nothing to be done for 'all'.
make[2]: Leaving directory '/home/t/bin/transcode-1.1.7/encode'
Making all in export
make[2]: Entering directory '/home/t/bin/transcode-1.1.7/export'
/bin/bash ../libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I..  -D_REENTRANT -DMOD_PATH=\"/usr/lib/transcode\" -I.. -I../src     -Wall -Wstrict-prototypes -Wmissing-prototypes -g -O2 -MT export_divx5_la-aud_aux.lo -MD -MP -MF .deps/export_divx5_la-aud_aux.Tpo -c -o export_divx5_la-aud_aux.lo `test -f 'aud_aux.c' || echo './'`aud_aux.c
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -D_REENTRANT -DMOD_PATH=\"/usr/lib/transcode\" -I.. -I../src -Wall -Wstrict-prototypes -Wmissing-prototypes -g -O2 -MT export_divx5_la-aud_aux.lo -MD -MP -MF .deps/export_divx5_la-aud_aux.Tpo -c aud_aux.c  -fPIC -DPIC -o .libs/export_divx5_la-aud_aux.o
In file included from aud_aux.c:48:0:
../libtc/tcavcodec.h:33:9: error: expected '=', ',', ';', 'asm' or '__attribute__' before '<' token
 include 
         ^
In file included from /usr/include/x86_64-linux-gnu/libavformat/avformat.h:319:0,
                 from ../libtc/tcavcodec.h:34,
                 from aud_aux.c:48:
/usr/include/x86_64-linux-gnu/libavcodec/avcodec.h:2456:25: error: field 'sample_fmt' has incomplete type
     enum AVSampleFormat sample_fmt;  ///< sample format
                         ^~~~~~~~~~
/usr/include/x86_64-linux-gnu/libavcodec/avcodec.h:2521:25: error: field 'request_sample_fmt' has incomplete type
     enum AVSampleFormat request_sample_fmt;
                         ^~~~~~~~~~~~~~~~~~
aud_aux.c: In function 'tc_audio_encode_ffmpeg':
aud_aux.c:883:16: warning: implicit declaration of function 'avcodec_encode_audio' [-Wimplicit-function-declaration]
     out_size = avcodec_encode_audio(&mpa_ctx, (unsigned char *)output,
                ^~~~~~~~~~~~~~~~~~~~
Makefile:860: recipe for target 'export_divx5_la-aud_aux.lo' failed
make[2]: *** [export_divx5_la-aud_aux.lo] Error 1
make[2]: Leaving directory '/home/t/bin/transcode-1.1.7/export'
Makefile:474: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/t/bin/transcode-1.1.7'
Makefile:381: recipe for target 'all' failed
make: *** [all] Error 2

So anyways, what would be the preferred method in 2019 if one wishes to extract the audio of a DVD movie? Alternatively, does one knows how to fix the make errors I am facing above?

Before installing UM 19.10 I used to evoke transcode and that fixed it. But now it seems this time has passed.

Cheers!

https://wiki.videolan.org/VLC_HowTo/Extract_audio/

You can also use "4K Video to MP3" which can be downloaded from here

It is a deb file so you can install it with Gdebi
Hope this helps

FYI - transcode was packaged in previous LTS releases (16.04 and 18.04).

But you can try to compile it after installing all dependencies:

sudo apt-get install build-essential devscripts debhelper dh-autoreconf liba52-0.7.4-dev libasound2-dev libavcodec-dev libavformat-dev libavutil-dev libavresample-dev libdv4-dev libdvdread-dev libfaad-dev libfreetype6-dev libjpeg-dev liblzo2-dev libmagickcore-dev libmagickwand-dev libmjpegtools-dev libmp3lame-dev libmpeg2-4-dev libpopt-dev libpostproc-dev libquicktime-dev libsdl1.2-dev libswscale-dev libtheora-dev libvorbis-dev libxaw7-dev libxft-dev libxml2-dev libxv-dev


cd ~/Downloads
wget http://archive.ubuntu.com/ubuntu/pool/multiverse/t/transcode/transcode_1.1.7.orig.tar.bz2
tar -xf transcode_1.1.7.orig.tar.bz2
cd transcode_1.1.7
wget http://archive.ubuntu.com/ubuntu/pool/multiverse/t/transcode/transcode_1.1.7-9ubuntu2.debian.tar.xz
tar -xf  transcode_1.1.7-9ubuntu2.debian.tar.xz
debuild -b

but even with all these steps it does not compile because of changed API:

...
export_ffmpeg.c:1229:22: error: ‘AVCodecContext’ {aka ‘struct AVCodecContext’} has no member named ‘me_method’
     lavc_venc_context->me_method = ME_ZERO + lavc_param_vme;
                      ^~
export_ffmpeg.c:1229:36: error: ‘ME_ZERO’ undeclared (first use in this function); did you mean ‘FP_ZERO’?
     lavc_venc_context->me_method = ME_ZERO + lavc_param_vme;
                                    ^~~~~~~
                                    FP_ZERO
...
make[2]: *** [Makefile:1094: export_ffmpeg_la-export_ffmpeg.lo] Error 1
make[2]: Leaving directory '/home/mate/Downloads/transcode-1.1.7/export'
make[1]: *** [Makefile:591: all-recursive] Error 1
make[1]: Leaving directory '/home/mate/Downloads/transcode-1.1.7'
make: *** [Makefile:500: all] Error 2

So consider to use 18.04 LTS or other tool...

1 Like

Thanks to all for your replies however I forgot to mention one very important detail: am looking for a single WAV extraction. In other words, have all tracks condensed as 1 big track.

Am afraid none of those suggestions have helped.

Might want to look at Avidemux it can rip to WAV format - you will need to have ffmpeg installed first

A very good tutorial for installing Avidemux:
http://ubuntuhandbook.org/index.php/2018/10/install-avidemux-2-7-1-ubuntu-18-10/