19.10 - Terminator From Software Boutique (Replace With Byobu?)

The Terminator application when installed via the Software Boutique or from the apt repositories (probably same thing?) doesn't launch from the menu for me.

When launched from the command line the following error message is displayed:

ConfigBase::load: Unable to open /home/evereux/.config/terminator/config ([Errno 2] No such file or directory: '/home/evereux/.config/terminator/config')

If I manually create the file and directory this error message disappears. I think the installation of Terminator should create this folders.

Then within terminator if I then choose Insert Terminal Number the following python error is produced:

Traceback (most recent call last):
File "/usr/share/terminator/terminatorlib/terminator.py", line 642, in do_enumerate 
    term.feed(numstr % (idx + 1))
File "/usr/share/terminator/terminatorlib/terminal.py", line 1507, in feed
    self.vte.feed_child(text, len(text))
TypeError: Vte.Terminal.feed_child() takes exactly 2 arguments (3 given)

I then gave up and went looking for other options and installed Byobu Terminal from the apt repositories. Not only does this launch it's theming fits right in within Ubuntu Mate overall very nicely.

Thanks to all responsible for Ubuntu Mate. I've recently switched full time from Windows, distro hopped for awhile and have now settled happily with Ubuntu Mate.

I just installed Terminator from the Software Boutique. It did not appear in the Menu until after logging out and logging back in.

However it opened and worked successfully on a brand new Ubuntu MATE 19.10 install.

Can you give us some more specs on your system?

1 Like

I've re-installed Terminator today and it launched fine (from Software Boutique). Then logging out and back in and launching from the Menu was OK too.

Here are the all install logs from first installation (you can see I tried a few times):

2019-11-14 15:04:19 install terminator:all <none> 1.91-4
2019-11-14 15:06:59 install terminator:all 1.91-4 1.91-4
2019-11-14 15:18:35 install terminator:all 1.91-4 1.91-4
2019-11-14 15:39:03 install python3-newt:amd64 <none> 0.52.21-2ubuntu1
2019-11-14 15:39:03 install tmux:amd64 <none> 2.9a-3build1
2019-11-14 15:39:04 install byobu:all <none> 5.129-0ubuntu1
2019-11-14 15:39:04 install pastebinit:all <none> 1.5.1-1
2019-11-14 15:39:04 install run-one:all <none> 1.17-0ubuntu1
2019-11-14 17:54:14 install terminator:all 1.91-4 1.91-4
2019-11-14 18:00:53 install terminator:all 1.91-4 1.91-4
2019-11-15 11:44:13 install terminator:all 1.91-4 1.91-4

The system was not rebooted during this period.

My system specs.

Motherboard: Z370 GAMING PRO CARBON (MS-7B45)
CPU: Intel(R) Core(TM) i5-8600K CPU @ 3.60GHz
Memory: 16GB
Harddrive: : NVMe SSD Controller SM981/PM981/PM983 1TB

This machine was upgraded from 19.04.

Glad it's working now.

Sounds like something did not work correctly during the installation. You can take a look at /var/log/apt/term.log to see if anything looks odd during the install process.

1 Like