20.04.1 NIC Issue

I recently ungraded my server from 18.04 to 20.04.1. I had to use the "do-release-upgrade -d" command as it refused to see the latest LTS release.

The motherboard is an Asrock X370 Gaming Pro that includes an Aquantia AQC108 5gbps NIC. As long as I've had it, I've been using Marvell's driver for it and had no issues.

I upgraded to 20.04 and now there's issues. So, first I upgraded the kernel using UKUU to 5.4. When I tried to install the Marvell driver I got a message that the included driver in the kernel was newer. Ok, cool - remove the driver from the 5.4 kernel and I removed it from the previous 4.x kernel.

This did not solve the problem. The OS sees the NIC, but will not accept the IP being assigned by my router.

I've tried using ifconfig up/down, restarting - no changes.

Please help! Where do I start with the troubleshooting?

Hi Nejaa,
compile and try with this experimental driver. No warranty, but you nothing loose. In readme.txt figures your AQ 108

Maybe good idea update router firmware too.
Good luck!

Thanks, Tim. I'll give this a try, but I'm curious: a I have another desktop with the same hardware, also running 20.04 and it didn't need this additional experimental driver. What could cause my server to need this?

Uh, no idea, but I guess is related to kernel and perhaps distro. It's not first time this occurs with AQ 107,106. Mr Google tells some info about it. Other thing is possible a kernel bug between 18.04, 20.04 and 20.04.01, rarely. Try and see and be sure you're updated and upgraded.