[20.04.2] Touchpad hell

I've been using 20.04.2-latest on a laptop with a Logitech K400+ (basically a wireless keyboard with an embedded touchpad) for several months now and since during installation time I was able to 2x tap on the touchpad of the K400+ and MATE reacted to it as a double click (Same as when using the touchpad of the laptop itself).

Sometimes last week during a regular user session the 2x tap function of the K400 suddently stopped working for no valid reason. Yet the touchpad of the laptop still worked properly...

As I have looked around the other posts of this forum I have noticed somewhat of a history of Love in between the touchpad and MATE yet I wasn't able to find any other same exact behaviour yet I can tell you this:

$ cat /proc/bus/input/devices | grep -i touch   
N: Name="ETPS/2 Elantech Touchpad"

and that the touchpad option is enabled under Control Center.

Any ideas or what would be the proper next steps to diagnose this unique little problem of mine?

Not sure if this might help ... give it a try.


Hello @DLS
If you press the function key and the left mouse key together, does it work then?
This would disabled/enabled tap to click (in theory).

If not, does a tripple tap result in a double click?

After a much needed follow-up:

  1. Thanks for both of your answers <3
  2. @Geus that's the one! SOLVED.

Cheers guys!

1 Like