20.04 install will not shut down: "GPU lockup - switching to software fbcon"

New SSD install of Ubuntu-Mate 20.04 (UEFI/GPT) hangs on shutdown with this error message:

nouveau 0000.01.00.0: DRM: GPU lockup - switching to software fbcon

Shutdown hangs whether the SSD is placed internally or externally.

My graphics info from the inxi program:

Graphics:  Device-1: NVIDIA GF106 [GeForce GTS 450] driver: nvidia v: 390.138 bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.8 driver: nvidia unloaded: fbdev,modesetting,nouveau,vesa 
           resolution: 1: 2560x1600~60Hz     2: 2560x1600~60Hz 
           OpenGL: renderer: GeForce GTS 450/PCIe/SSE2 v: 4.6.0 NVIDIA 390.138 direct render: Yes

To no avail, I've tried putting (one at a time) all 4 of nouveau.noaccel=1 ; nouveau.noaccel=0 ; nouveau.nofbaccel=1 ; and nomodeset in the "GRUB_CMDLINE_LINUX_DEFAULT=" line of the /etc/default/grub file, per advice on several forums and blogs. There's lots of talk about this error on the web, but no fix that has worked for me.

I had to change GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="" in order to see the "GPU lockup" error message in the console.

I also had to change from my nvidia driver to nouveau in order to see that message, since nouveau plays much nicer with the console on my machine: the print is smaller and sharper using nouveau. Console print using nvidia is too large and I couldn't see the last line, which contained the error message. But shutdown hangs using either driver.

I'm writing this from my 18.04 install, but here is more info re my setup (I'm using the same kernel version on both the 18.04 and 20.04 installations, which are on separate drives):

--> sudo lshw -C display; lsb_release -a; uname -a 
  *-display                 
       description: VGA compatible controller
       product: GF106 [GeForce GTS 450]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: [email protected]:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:35 memory:ec000000-ecffffff memory:e0000000-e7ffffff memory:e8000000-e9ffffff ioport:e000(size=128) memory:c0000-dffff
LSB Version:    core-9.20170808ubuntu1-noarch:security-9.20170808ubuntu1-noarch
Distributor ID:    Ubuntu
Description:    Ubuntu 18.04.5 LTS
Release:    18.04
Codename:    bionic
Linux rjbox 5.4.0-51-generic #56~18.04.1-Ubuntu SMP Tue Oct 6 09:47:18 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux 

One of the bugs in the 20.04 installer is that it will run almost until finish but freezes toward the end of its run, unless you un-check the third-party graphics button. Can't help but think this may be related to the hang. Is some graphics file or library not being installed that should be, because of this bug of having to uncheck install of third-party graphics?

Can't understand why I'm getting this hang, since my nvidia driver is the latest available for my card.

(Also, I installed 20.04 on two separate external disks and both suffer from the same problem: upon shutdown they appear to close all running processes, but in both cases they leave the machine running.)

I'm hoping for suggestions as to how to get the install to shut down properly.