20.04 Installer crash on Raspberry Pi Compute Module 4

OS: Ubuntu MATE 20.04.1 arm64
Target: Raspberry Pi Compute Module 4 (CM4001008, also tried CM4102016)
Carrier: CM4IO Board

Here are the steps I followed:

  • Download ubuntu-mate-20.04.1-desktop-arm64+raspi.img.xz and verify checksum.
  • Disable eMMC boot on CM4IO board with a jumper on J2.
  • Connect J11 USB slave to Xubuntu 18.04 host.
  • Use usbboot latest master branch (commit: 9324fd7), and mount the eMMC on the host.
  • Flash the image using BalenaEtcher (AppImage) v1.5.108, also tried Raspberry Pi Imager (snap) v1.6.1.
  • Add dtoverlay=dwc2,dr_mode=host on partition: system-boot, file: usercfg.txt. (Also tried /boot/firmware/config.txt but the USB was not enabled).
  • Connect ethernet. (Also tried without ethernet).
  • Boot CM4 and complete the MATE installation forms.


  • Installer: Configuring system locales... (takes about 5min)
  • Installer: Configuring keyboard...
  • Pop-up appears with title: Installer crashed (on Ubuntu).
  • After submitting the report, a firefox window opens but it just hangs.

After rebooting:

  • If there was ethernet connection, the installation restarts
  • If there was no ethernet connection, the login screen appears but the user I filled in the form was not created, so the system is unusable.

I need to run a non-standard resolution display over HDMI, and MATE was the only available OS for CM4 I found that supports it. Any workarounds or other OS recommendations are welcome!

I encountered the same problem. Any solutions?

I suspect I ran into the same problem. I have the MATE image mentioned above but could not get it to work.

Instead I used the Ubuntu server 20.04.2 for Pi. Then apt-installed other things I wanted, including Tasksel. Using Tasksel, I installed MATE desktop core.

That works. Everything is installed. It generally works although I am encountering heinous crash bugs when I logout or switch user.

I am having the same problem watching the "configurng keyboard" the third time.

1 Like

Welcome @Stan_Suen to the community!