22.04: Two Print Issues


I recently upgraded from UM 20.04 to 22.04, and have had a good experience in the process but there were/are two small problems. -

  1. (SOLVED) Could not print directly to a printer from within the Firefox snap. I got past this by issuing the following in a terminal. perhaps this will help others.

sudo snap connect firefox:cups-control

See https://askubuntu.com/questions/1260603/how-can-i-print-from-the-snap-packaged-version-of-firefox for background info.

  1. (NOT solved) The print indicator does not work no matter where I print from/to. I checked to see that "ayatana-indicator-printers" was installed. I have the "Indicator Applet Complete" installed in the panel. I don't see another indicator applet for printers, so I assume that it is part of the "complete" package, but I don't know that. Have not been able to figure out a solution on this one. Perhaps someone can offer a suggestion.



Hello astrogenealogist

I also have problem no. 2 after upgrading. I set up a work-around by adding a launcher to a panel thus:

You could try that - remember that you have to press CTRL + F to get the printer queue to open. :slightly_smiling_face:


Thank you alpinejohn. I will give it a try.