3.5mm audio output not working on RPi4 with 20.04

Fresh install of MATE 20.04 Beta1 aarch64 on a 8GB Raspberry Pi 4. Connected via HDMI to two monitors, both without sound support. Powered speakers attached using the 3.5mm audio jack. RPi is using firmware 000137ad

Running "sudo amixer cset numid=3 1" returns the error "amixer: Cannot find the given element from control default"

From the hardware tab of Sound Preferences, I see three devices (assumed HDMI1, HDMI2, 3.5mm). Using the Test Speakers button on each of the three does not output audio from the speakers. (no audio over HDMI is expected)

Audio works as expected using 2020-05-27-raspios-buster-full-armhf.

Anyone else seeing this behavior or have working 3.5mm audio output on 20.04?

I have 1 HDMI connected: by default sound comes out 3.5 mm audio jack
working on RPi4 4 Gb with MATE 20.04 => OS 5.4.0-1015-raspi 64 bit

I too am having this issue. I can get sound to work from my HDMI monitor speaker. I have to reset it every time I reboot but I cannot get sound from the 3.5mm audio jack. I'll donate $10 if someone can get this to work.
-Computer-
Processor : 4x ARM Cortex-A72
Memory : 3884MB (2150MB used)
Machine Type : Single-board computer
Operating System : Ubuntu 20.04.1 LTS
-Display-
Resolution : 3840x1080 pixels
OpenGL Renderer : V3D 4.2
X11 Vendor : The X.Org Foundation
-Audio Devices-
Audio Adapter : bcm2835_hdmi - bcm2835 HDMI 1
Audio Adapter : bcm2835_hdmi - bcm2835 HDMI 2
Audio Adapter : bcm2835_headphonbcm2835 Headphones - bcm2835 Headphones
-Input Devices-
Microsoft Microsoft Basic Optical Mouse v2.0
Dell Dell USB Entry Keyboard
-Printers (CUPS)-
HP_OfficeJet_Pro_8720_7E4518_

So I re-imaged the SD card and ran the setup again because I had some weird monitor issue the first time I installed. Same results. I can get sound from my monitor with HDMI if I reset the hardware and output. But I cannot get the 3.5mm audio jack to work. Bleh. Otherwise this is a nice distro and I like th eway it works on the RPi4.

1 Like

Here are some outputs from a mixer
Simple mixer control 'HDMI',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback -10239 - 400
Mono: Playback 400 [100%] [4.00dB] [on]

amixer controls
numid=2,iface=MIXER,name='HDMI Playback Switch'
numid=1,iface=MIXER,name='HDMI Playback Volume'

amixer contents
numid=2,iface=MIXER,name='HDMI Playback Switch'
; type=BOOLEAN,access=rw------,values=1
: values=on
numid=1,iface=MIXER,name='HDMI Playback Volume'
; type=INTEGER,access=rw---R--,values=1,min=-10239,max=400,step=0
: values=400
| dBscale-min=-102.39dB,step=0.01dB,mute=1

I don't see headphones on here nut if I run alsamixer I see these cards.

  • (default) │ │
    │ │0 bcm2835 HDMI 1 │ │
    │ │1 bcm2835 HDMI 2 │ │
    │ │2 bcm2835 Headphones │ │
    │ │ enter device name...

It's the same on my raspberry Pi 4 4GB with MATE 20.04 armhf.
I've two monitors working and therefor I have to commend the line hdmi_drive=2 in config.txt because else the monitors wouldn't work.
I get the same error running "sudo amixer cset numid=3 1" as linux203.
And it works on RaspberryOS as well.

any suggestions?

Hey there. I've got it working.
Try to put in another line to your config.txt with this content: audio_pwm_mode=2