A dual-band USB Wi-Fi Adapter that works - and how to find them

networking

#1

Purchasing wireless equipment can be a bit tricky, as there is a chance any off-the-shelf adaptor (especially the latest models) won’t work out of the box (due to no driver being in the kernel/repositories) or even worse… it has a chipset that isn’t even supported at all!

So if you’ve got a 5 GHz / 2.4 GHz router and in need of something that can reliably transmit through 2 floors in a house while sustaining decent speeds to the network - this 2016 adaptor is a good candidate:

What did I find?

Asus USB-AC68 Dual-Band AC1900 USB Wi-Fi Adapter

  • USB 3.0
  • 1300Mbps - 3-stream 802.11ac device (433Mbps per stream),
  • 600Mbps - 3-stream 2.4GHz 802.11n (256QAM) = 1900 Mbps class
  • Dual antennas – (my dad describing it as “alien” looking :joy: )

Bought from eBuyer for £57.99.

Technically known as:

Bus 001 Device 006: ID 0b05:1817 ASUSTek Computer, Inc. 

(Two floors below, my router is a TalkTalk Huawei HG635 VDSL 802.11ac)

This adapter won’t work out of the box, but that’s OK!

With a bit of research, this ASUS USB-AC68 has the Realtek RTL8814AU chipset.

Wikidevi is very helpful in identifying whether a driver is in the upstream kernel (e.g. works out of the box), or if there is or isn’t a known driver that will allow the device to work.

Luckily, I found a driver in this repository and had a good feeling I’ll be able to compile it once I order it. (It delivered, it worked! :smile:)

I did come across a few other repositories that provided a driver for the same chipset, but this one seemed more up-to-date and promising.

DKMS Support

This driver has DKMS support which will save headaches later. This is so the driver can be re-compiled when the kernel is updated, otherwise the device would stop working when you update your system.

What commands did I use?

sudo apt-get install git dkms
git clone https://github.com/nazar-pc/RTL8814AU.git
cd RTL8814AU
sudo ./dkms-install.sh
sudo modprobe rtl8814au

Is it future-proof?

This particular driver repository was also kind to specify which versions it worked on:

Should work on modern Linux kernels from 4.9 to 4.14-rc2 (older and newer kernels might work as well, but were not tested, feel free to let me know if it works on others).

Currently being on Ubuntu MATE 16.04 LTS with the kernel at 4.10.0-30, I have faith it’ll continue to work from this point forward. :slight_smile:


Where to buy Open Source Network Card or Network Adapter(HW)
#2

Thank you so much mate. I’m a complete newbie to Linux and really struggled for quite some time with this one. I had no problem installing this in Win 10. Ubuntu was a real problem for me. I followed your instructions to the letter, and was blown away when I saw the little blue light on my Asus flicker. ! Thank you so much. It works. I don’t know why, but the light flickers continuously, unlike Win 10, where it’s just on all the time. ? Is there a diagnostic you might be able to suggest ? Sorry once again. This is quite challenging for me, but good. Thanks again for your info.


#3

Flickering indicates there’s network activity, you could open System Monitor and check if there is data being sent/received.

Funnily enough, this adaptor’s supplied USB extension caused a bit of bother, so you could try another port.

Alternately, it could be the driver, the official Windows one from ASUS and the various unofficial Linux drivers might differ in how they interact with the LED. Diagnosing would need specialist knowledge with the driver’s source code to understand if that’s the case.


A word of caution – I’ve noticed in later kernel versions the drivers won’t build anymore! So I’m holding onto a kernel version of 4.13.0-45-generic for now. I might have to see if there’s another driver or update to this repository.


#4

Good grief. ! Sorry, I’m a bit staggered at the speed, and volume of the information you’ve just supplied. I’ll have to spend a couple of hours reading that. ! Wow. ! Yea. Thank you so much. Like I said. The Windows 10 install was a piece of cake. Just stick the c.d. in and that’s it. With Ubuntu I turned myself upside down, d/l all sorts of kernels and modules and all I was getting was failed. ! Also, yes. I read what you, and others had to say about updating and losing those settings. I’m pretty sure that’s what’s going to happen with me, as half the time I’m probably updating things that I shouldn’t, which is really a bit hit and miss. The light flickering thing… yea. I thought the same… data transfer… stands to reason, but like I said with Win10, it’s on constantly. ? Doesn’t matter. It works. ! When it stops, I’ll re-visit your extremely helpful bookmark. Cheers from N.Z. mate. Ta.


#5

No problem! Things will certainly be a lot easier in the Linux world when manufacturers produce drivers integrated into the kernel (i.e. plug & play), not just Windows. :unamused: Till then, we’ve got to rely on community efforts to get hardware working – especially more modern hardware like dual-band Wi-Fi adapters.


#6

Brilliant. ! Thanks very much for all your help & advice Luke. I’ll keep an eye out for you in the channels. Cheers.


#7

Thank you for this post: you made it easy for me to deal with this irksome issue!
Cheers from NZ, Annalemma