AArch64 on Raspberry Pi 2 (rev 1.2), 3B, 3B+


#44

I used win32DiskImager. I’m not getting any other messages. It displays after the Errors
“BusyBox v1.27.2 (Ubuntu 1:1.27.2-2ubuntu3) built-inshall (ash)
Enter ‘help’ for a list of built-in commands.”


#45

Have you tried booting without the keyboard attached to see if the usb hub messages are significant?

If that still doesn’t work, re-attach the keyboard and when you are at the blue splash screen press the escape key. You may possibly see an error message.

I can’t think why it is not working. Really strange. I’ll have a sleep on it.


#46

With the keyboard it gets rid of the usb hub messages but it still takes me to the command line after the splash screen is up for about 20 seconds.


#47

You usually hit busybox if it can’t find the root filesystem. If you do a search there is plenty of info on the net e.g. https://askubuntu.com/questions/137655/boot-drops-to-a-initramfs-prompts-busybox

It’s usually the filesystem has been corrupted, or the device is being super slow to power up. At the moment I can’t think of anything else.


#48

Just to demonstrate you can install any desktop environment, here’s the latest kde neon desktop running on the pi 3:


#49

I know this is the wrong forum to express this, but you have to admit kwin is impressive. There’s not many window managers that can be used under Wayland on the pi 3!


#50

Thanks for putting this together. Nice to have Xubuntu running on my 3B+.
What needs to be done after install to get wired ethernet to work?
I ran:
sudo ip link set dev eth0 down
sudo dhclient eth0
but wired connection does not function.
Debian networking is not my strong point.
Thanks for any help anyone can offer.


#51

Hi crashyz, Ethernet should just work when you plug the cable in. Xubuntu has a network manager GUI that takes care of it all. Have you edited any text files that may have stopped it working?


#52

It works in Mate version. It works on the install of Xubuntu, as it downloads updates and 3rd party files during install. The 1st time I installed Xubuntu I noticed it wasn’t working. After reading about possible causes and trying different CL commands to try to get it working I figured I messed something up, I reinstalled Xubuntu. Still no ethernet.
Settings>Network Connections Ethernet shows up
ifconfig eth0 shows up
in the taskbar when the network manager icon is clicked Ethernet Network is greyed out and is listed as disconnected.
etc/network/interfaces:
“# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback”
If I run “ifconfig eth0 down && ifconfig eth0 up” I get “ifconfig: Host name lookup failure”
restarting network manger won’t start it either.
Any ideas?
Kind of seems like the driver/firmware isn’t getting loaded at boot. The only screen output at boot refers to the wireless, which is working.


#53

some more fiddling…
sudo lshw -C network = *-network:0 DISABLED
then did the following
"Create a new file instead: /etc/NetworkManager/conf.d/10-globally-managed-devices.conf which overrides the first one. Make it empty or comment its content with the hash symbol:

[keyfile]

unmanaged-devices=*,except:type:wifi,except:type:wwan"

sudo service network-manager restart
notification pops up now connected to wired network, but no ethernet connection (even though eth0 is listed in Network Manager).
that is the extent of my network knowledge.


#54

There’s a couple of things you can check:

In the cmdline.txt file there is net.ifnames=0. In the pi server image this is used (which is why I used it), but it is not normally used on other architectures. When I’ve installed using this boot parameter and then later removed it, networking has stopped working. Check that is still there or play around with it?

Check you have the 3B+ device tree in /boot/firmware.

Install xubuntu without the Ethernet cable attached. Once installed re-attach and see if you have Ethernet. My suspicion is that an update to a package has knocked it out. Maybe the Linux-raspi2 packages? See if you can work out the offending package?

Networking has changed recently and it is easy to follow old information on the internet and mess things up. As a rule Debian wiki pages are usually not bad ( e.g. https://wiki.debian.org/NetworkConfiguration ), but I really don’t know a lot about networking.


#55

The net.ifnames=0 is in cmdline.txt.
There is nothing in the /boot/firmware folder
But…
I reinstalled the 64 bit version again without updating during install or 3rd party. Still no ethernet
But…
Installed the 32 bit version and had both wifi and ethernet working.
ran sudo apt-get update and sudo apt-get upgrade
then ran sudo apt install ^xubuntu-desktop
then update/upgrade again
Then Xubuntu’s software updater pops up stating there are updates since 18.04 came out, do I want to update? Sure, why not.
Updates, then tells me to reboot.
After rebooting I have a fully updated system, but now no ethernet connection again, so it must be something in the update causing the disabling of the ethernet.
I’m going to reinstall the 32 bit version and skip that final update process.


#56

This would suggest it is not an update causing the problem. Maybe just one of those intermittent errors? There were a lot of bug fixes for the 3B+ Ethernet at the time of the 18.04 release. It is very likely they weren’t all included in the 18.04 raspberry kernel. You maybe just have one of those niche setups that cause problems?

18.10 is released on Thursday. You could try that, installed via the netboot/mini installer as I have described above. Lubuntu with the LXQT desktop environment and kwin as the window manager would work pretty well on the pi I would imagine.


#57

I’ve ran Kubuntu on all of my home PCs for the last 6 years. I installed KDE on a Mate 16.04. Looked nice but was painfully slow. That was one of the reasons I like Xubuntu, it has somewhat the same feel as KDE. Something about Mate I don’t like.
The kicker of the whole deal was I got the Pi to run VNC on. I live in a rural area and I am on wireless that is behind several layers of NAT, so I can not directly access my CCTV system. ISP wanted $15 extra a month for a static IP. It was way cheaper and more fun to set up the Pi. Only thing is this morning I finally read that RealVNC only works on 16.04, so it won’t work on these 18.04. I’ll have to look into other VNC options because these Xubuntu installs are what I have been looking for.
Thanks


#58

There are the flavour maker builds of xubuntu 16.04. All you have to do is update the firmware and kernel to make it useable on the pi 3B+. Or you can install via the mini/netboot again. 3B+ is supported in the latest Linux-raspi2 kernels of 16.04. (As far as I know) Firefox doesn’t work in 16.04 armhf, but you can use chromium or Vivaldi.


#59

OK, I failed to unplug the network cable during the 64 bit install. It should have registered when the screen said it was downloading language packs. I unplugged the cable and installed again. Plugged the cable in after install and reboot and… working wired connection.
There is some update somewhere that is killing it, because it is happening on the 32 bit version too after the xubuntu software updater. At least the source of the problem has been found hopefully. I’ll have to take a look at the list of packages that last update installs and see if I can’t figure which one is causing the problem.


#60

Probably stating the obvious, but run lsmod and save the logs on a working install so you have something to compare when it doesn’t work.

Ignore what I was saying about the Linux-raspi2 kernel in 16.04. Going by this thread https://forum.snapcraft.io/t/support-for-raspberry-pi-3-model-b/4509/43 it is still missing some patches.


#61

Installed with no problem. Both wired and wireless networks fine. Did a software update, rebooted and wired network dead. So am pretty sure is a problem with an updated package. Looking at install log, a lot of stuff got updated so not clear
what problem package is. Both kernel and dtb updated to 4.15.0-1027.


#62

I just did a fresh install and I can’t recreate the problem with my 3B. I’m only using Ethernet though, no switching between wifi/Ethernet…not sure if that is significant?? It would seem to be a kernel problem with the 3B+?


#63

The kernel looks like it has been updated from 4.15.0-1010 to 4.15.0-1027, along with changes to the dtb. Converting the dtb’s to dts’s and looking for changes I see that in both there is an alias for ethernet0:

ethernet0 = “/soc/[email protected]/[email protected]/[email protected]/[email protected]”;

But in the 1027 version there is also a symbol defined (in symbols section):

ethernet = “/soc/[email protected]/[email protected]/[email protected]/[email protected]”;

Not enough of an expert in this area to know if relevant or not.