About os-prober and the problems with it being disabled

in 22.04 os-prober is disabled and that will be a problem for many people new to linux, most of which will be dualbooting.

They will simply think that windows will be deleted and they will think that linux is not suitable for them.

Is it possible to fix this issue?

The update-grub command gives a warning about it, and helpfully points out the entry to put into /etc/default/grub to reenable os-prober. Beyond that, maybe a notice or link to a howto on Ubuntu MATE Welcome?

Check Bug #1955109 “boot menu not appearing after manual install of je...” : Bugs : grub2 package : Ubuntu to know that it is fixed in the following way

Only run os-prober on first run and if it previously found other OS

So it should run during the install procedure.

If it is not - then open /etc/default/grub to add GRUB_DISABLE_OS_PROBER=false and then run sudo update-grub.

1 Like

Have you tested it?

I don't believe it is an issue. Yes in early QA testing it was an issue where my multi-boot machines ended up only with the new install listed in grub 2.06, but it's not been that way for some time.

On the Lubuntu jammy issue tacker that was listed as the first issue, it was marked as resolved on March 27, and was later dropped from the list of items of concern.

I've had the same results with Ubuntu-MATE jammy as well.

FYI: the date I listed was from the history of the issue tracker (it was quick & easy to get).. The change will be documented in bug reports & I can find the actual date if required, but I don't see it as necessary.. The issue hasn't been reported in QA-testing for some time, see List of results for bug #1955109 (and its duplicates) | Ubuntu QA

1 Like

Question also asked at Os-prober and the problems with it being disabled - Ubuntu Budgie

1 Like

Thanks everyone. I just installed Kubuntu 22.04 and i noticed it showed the dualboot menu without any problems after installation. Turns out i hadn't tried it out like guiverc suggested! :slight_smile: