Acer ES1-331 Fan Problem

Hello there. After a really long distro hooping i’m settled back to Ubuntu Mate. I’m really liking it but i have a one problem.

My cpu fan is working, sometimes. And sometimes not. I do not know which causes this and how to track it down.

Let me start from beginning. When i booted from usb, fan is just working fine. After installation and reboot, it continues to work well, too. But after a one day or another, its just doesnt work. Since my cpu is not the powerful one, my laptop does not get really hot (not above 60C) but i feel it when using in bed or something like that. If my fan works i hope it’ll be cooler.

Now i’m just asking this, how can i track down my problem and solve it?

Edit: I forgot to mention. I tried all of kernels out there when i’m using arch. Even with the silvermont optimised ones. None of them solve this.

Seems to be an ongoing problem for acer users.

Sorry but i cant see any problems related to mine. They are just other fan problems. None of them having weird problem like me.

Hi @peyloride,

are you blocking the fan intake by using the laptop on a bed or sofa?, have you checked whether the fan is actually turning?, is there any dirt or fluff in the fan intake?, is there a blanket or an item of clothing causing a fan intake blockage? . Only use a laptop on a flat surface so the fans don’t get blocked!. :thumbsup:

Get one of these to avoid such problems:

If that happens on many distributions you tried, it could be you really need to clean your fans, I did that once on an old laptop and improved its performance. On another one that fan was just almost broken, like burnt and I should have to replace it but I bought another laptop.

That might be a problem if i didnt buy my laptop 2 months ago. I dont think its caused because any dust or something like that.

I dont think its realted to hardware because when booting on Acer logo or grub screen every single time fans works perfectly. After booting distro, it just powers off.

It might be the power save mode. I have a speaker clicking noise on my acer which is related to the “something unknown” … google about clicking noise and speaker. There you will find some tweaks which I was not able to do successfully. Maybe you can do it.

However, as far as I know, you should be able to avoid the powersave mode by plugging in your laptop. Give that a try and see how that works. Then you can try to tweak the powersave settings once you know that is it. (if you can)… and let me know too. I’d love to remove the clicking noise from the speaker! Acer… bad choice for Ubuntu Lovers. Same is true for cannon printers.

1 Like

Oh dear. You are right. When i plug cable in, fan works perfect. I’ll investigate this further. If i know something related, i’ll let you know. Thank you.

1 Like

glad to help. remember to get back to me on your successful tweak.

i have the same problem on my aspire es1-531, the fan only work for some seconds when i boot my laptop.
this guy says that this kernel solved the problem
can anyone tell me how to install this kernel, please? i have ubuntu mate 16.04.1

Then, you have no problem at all. It is supposed to work that way if power saving is set on BIOS and OS. First it goes at full speed and then it changes t a lower one because the temperature is OK. If it would need to lower the temperature it will put more speed on the cooler.

When you plug the cable it stops the power saving as it does not need to save battery because now is changing it and feeding the laptop thru the wired net of electricity.

Also, you don't use the laptop on a blanket.

Same goes for you @avestruz123

It doesn’t work.
I tried with Windows and runs correctly.

Then you don't have the same problem.

I dont think you understand me and @avestruz123’s problem right. When laptop gets warm or over 60C fan needs to work but it does not. Even when under 60C or any temperature, fan must work but sliently. On Acer Aspire ES1-311 or similiar products; it does not work at all. Only some situations it works; like after kernel upgrade or something randomly happens. This is definitely a bug but i dont know the cause is Acer or Linux kernel.

Look how to change the setting to make it work. That's happening because it is saving battery, as I say. Also try setting nolapic in grub.

I’ll try nolapic setting tomorrow. But i must say, fan doesnt work everytime i plug cable. Sometimes it works with only battery.

It doesn't work for me.

Well, then you’re probably screwed. You can try installing in BIOS legacy mode but if nothing works, then you’d have to wait ages till a kernel supports it or a driver from vendor comes in or finding a patch. Or you can try by grabing a newer kernel at

I installed kernel 4.9rc6 and now works.

I did install Rc5 yesterday, fan works after kernel upgrade but after second restart; still not working.