Acer Laptop not shutting down properly

Hi Everyone,

Wondered if you can help with a shutdown issue I have?

If I choose to restart, suspend or shutdown, it hangs on the Logo and the square dots stop their rotating colour change procession.

Is there anything I can do to stop this happening?

I have to hold down the power button at the moment in order to turn it off.

Thank you in advance,


The system being run is this:

System: Acer (portable)
product: Aspire E1-410
v: V2.05
Mobo: Acer
model: Aspire E1-410
v: V2.05
Bios: Insyde
v: V2.05
date: 03/11/2014
Card: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
Display Server: 1.18.3
drivers: intel (unloaded: fbdev,vesa)
tty size: 170x48
Advanced Data: N/A out of X

Hi @Phil_Claffey,

have you done a full system update?:

Hi Wolfman,

Yes, updated.



@Phil_Claffey, It sounds like you are experiencing what is currently a fairly common issue; but maybe not... If so, though, an easy workaround may be in order for you.

I don't know if your update fixed your shutdown lag; but there are a half dozen risky commands to breeze past this annoying issue, as well as what you do: [quote="Phil_Claffey, post:1, topic:6388"]
I have to hold down the power button at the moment in order to turn it off.

Whatever is causing it may never be found, e.g., systemd bugs, lagging daemons, programs that won't quit, or any number of other shutdown/reboot issues. But a good, safe, workaround (community link below) will help you forget about it. :smiley:

Please try this the next time it hangs: Magic SysRq key trick
(If you don’t have a SysRq key use the PrintScrn key instead)
Hold ALT + SysRq and while holding type reisuo.

It’s not a fix for your problem but it might be better than a hard reboot

It will not shut down at all or will it hang for exactly 90 seconds (which is systemd default).

Hi @Phil_Claffey,

if you keep updating; it should sort itself out, this was happening on my HP Compaq PC but is now resolved!. :smiley:

It hangs eternally. Thanks though! ;O)

I wait in vain… ;O(

Stick with it Phil!. :thumbsup:


Thanks Wolfman, it’s been freezing with YouTube and Open Office a few times in the last 24 hours.

I so love this OS, be great if it would suspend, but hey, apart from that an a couple of crashes, I really cannot complain at all.



Hi @Phil_Claffey
The freezing while playing video and your processor type makes me think you might be another victim of bug 109051.

You should try adding intel_idle.max_cstate=1 to your kernel arguments and see if that fixes thing.


1 Like

Thank you Ouroumov,

How to I get to the kernel arguments?

Sorry, I am a bit of a novice when it comes to Ubuntu.

I presume it is through the terminal, once in there and I paste the ‘intel_idle.max_cstate=1’ it tells me that the ‘command not found’.




Easiest way:

sudo pluma /etc/default/grub



So it reads:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_idle.max_cstate=1"

Then run the command:

sudo update-grub

... and reboot


A post was split to a new topic: Shutdown taking a very long time

@Phil_Claffey, did you try that from my last post?

Hello Ourmov,

yes, still the same.

Thank you though.

It also freezes when I unplug the power supply.


Hi Phil,
I have the same problem. It is caused by Intel bay trail cores and the bug is affecting many.
I have a solution which isn’t the best but still good and valid for Ubuntu 18.04 users too.
first open terminal by pressing ctl+alt+T
then type the following commend : sudo gedit /etc/default/grub
find and edit GRUB_CMDLINE_LINUX_DEFAULT="quite splash" into GRUB_CMDLINE_LINUX_DEFAULT="intel_idle.max_cstate=1"
Then save and close the grub
Now you have to update Grub, just use the following commend sudo update-grub
Turn off your laptop forcefully for one last time cause after that you are not going to have this problem after you Boot it up again.
Hope it helps