ACPI errors when booting from USB


I just tried to install Ubuntu mate for the first time. I have used it in virtual box but now I wanted it as my main operating system. I downloaded the official 64-bit .iso file and wrote it to my USB-stick.

When booting from it, everything was fine at first. It asked if I just wanted to try it or install it. I chose to install it. Immediately after that I got bunch of errors. Few lines of clear errors and then a lot of unreadable stuff.


I tried both available versions of Ubuntu mate (16.04.3 and 17.10.1). Also tried unetbootin as alternative to rufus. Everything had the same result.

I haven’t had these errors with other Linux operating systems I have used (eg. openSUSE).

My system:

  • Z170 PRO GAMING (Bios version shouldn’t be that old)
  • i7 6700k
  • Asus 1060
  • 16GB DDR4 non-ecc
  • 3 HDD and 1 SSD

Hi Maineri,

boot the live CD again and then press any key to open the menu, press F6 and select “no acpi” from the list and try it!. :smiley:

I don’t quite understand what you meant but I think I got it working.

When rufus asked if I wanted to write it as ISO or DD I took DD. Now it still gives the errors but also opens the installing menu.

Thank you!

Okay now I got it installed but it doesn’t boot anymore.

Now I get this and the old errors:

[Firmware Bug]: TSC_DEADLINE disabled due to Errata; please update microcode to version 0xb2 (or later)

Hi Maineri,

what did you select for the type of partition scheme?:


I've also this issue when I load the bootable usb and select the start ubuntu or install ubuntu these ACPI error appears. Please suggest me what should i do?
System Configurations:
-Haier Y11C