Adafruit-pitft-helper unmet dependencies

I just installed Ubuntu MATE 16.04 on a Raspberry Pi 2 and am trying to get the Adafruit 2.8" resistive pitft working by following this guide:

but when i run
sudo apt-get install -y adafruit-pitft-helper

i get:

The following packages have unmet dependencies:
adafruit-pitft-helper : Depends: tslib but it is not installable
Depends: libts-bin but it is not installable
E: Unable to correct problems, you have held broken packages.

I’ve looked around a bit for help and tried a few things:
sudo apt-get -f install
sudo apt-get remove --purge tslib (found that tslib is not installed at all, so not just a broken package)

I’ve also enabled main, universe, restricted and multiverse sources/repositories, but I don’t know enough about Ubuntu or linux to understand what the problem is.

You can try to compile it your self.

Let me just try to throw inn some instructions here

sudo apt-get install git build-essential #Installs tools to download and compile the software
git clone #Downloads it from github
cd tslib #changes directory to the folder where the files got downloaded
./configure #runs the configure script with default settings
make -j 4 #compiles the software with 4 threads
sudo make install #installs the software

Maybe it will still say its missing, but then you can try to force install it (it should work if the debian installer file that it is depending on installs to the same location as is default in the configuration script)

Hi , tried your code but not working

Not sure when you put out this code, but is there a later version?

Pi 3, pitft 2.8 display, ubuntu-mate 16.04.1 LTS