Adding Microsoft fonts to 18.10

I downloaded the fonts with “sudo apt-get install ttf-mscorefonts-installer” and then open Libre and they are not listed. I have a laptop with Ubuntu 18.01 and I was successful installing the fonts there. Any suggestions as to getting the fonts to show up in 18.10?


I followed

Can’t help solving the issue on your side, but I can conform that installing fonts worked fine in my Virtualbox.

Are the fonts in /usr/share/fonts/truetype/msttcorefonts?

Did you get any error when you installed them? A while ago, there was an issue with the package because it downloads the fonts from a specific place and they had been moved elsewhere. It’s supposed to be fixed since then but maybe the same issue reappeared recently.

1 Like

No errors. Went through the installation process a second time and said it was installed. I had just finished installing it on my laptop 18.04 successfully. When I tried on 18.10 the fonts didn’t show up after installation. It’s not a problem without them. I was just standardizing the different platforms I have. It’s more like a puzzle solving problem. Thanks for you question.

I tried again by removing and reinstalling without success. There were errors I see in terminal.

john46@ubuntu:~$ sudo apt-get install ttf-mscorefonts-installer

Reading package lists… Done

Building dependency tree

Reading state information… Done

The following additional packages will be installed:


The following NEW packages will be installed:

cabextract ttf-mscorefonts-installer

0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.

Need to get 21.8 kB/47.1 kB of archives.

After this operation, 168 kB of additional disk space will be used.

Do you want to continue? [Y/n] y

Get:1 cosmic/universe amd64 cabextract amd64 1.6-1.1 [21.8 kB]

Fetched 21.8 kB in 0s (119 kB/s)

Preconfiguring packages …

Selecting previously unselected package cabextract.

(Reading database … 193505 files and directories currently installed.)

Preparing to unpack …/cabextract_1.6-1.1_amd64.deb …

Unpacking cabextract (1.6-1.1) …

Selecting previously unselected package ttf-mscorefonts-installer.

Preparing to unpack …/ttf-mscorefonts-installer_3.7ubuntu4~really3.6ubuntu3_all.deb …

mscorefonts-eula license has already been accepted

Unpacking ttf-mscorefonts-installer (3.7ubuntu4~really3.6ubuntu3) …

Processing triggers for update-notifier-common (3.192.7) …

ttf-mscorefonts-installer: processing…

ttf-mscorefonts-installer: downloading


Redirection from https to ‘’ is forbidden [IP: 443]

E: Failed to fetch fonts/final/andale32.exe Redirection from https to ‘’ is forbidden [IP: 443]

E: Download Failed

Setting up cabextract (1.6-1.1) …

Processing triggers for man-db (2.8.4-2) …

Setting up ttf-mscorefonts-installer (3.7ubuntu4~really3.6ubuntu3) …

Processing triggers for fontconfig (2.13.0-5ubuntu3) …


Looks like it’s trying to use a SourceForge mirror that has issues. I think that it switches to it depending on your location, as if I try to download the file directly, it switches to a different one for me.

Given that the mirror ( gives you a “forbidden” error, it’s possible that your connection is filtered for some reason. Are you on a public internet connection, or maybe an university/enterprise one? or a mobile connection with limits? are you behind a proxy?

What happens if you try to download the file with the following command? It won’t help installing the package, it’s to check if you get the same behaviour.

wget " fonts/final/andale32.exe"

If it doesn’t work better, does it with a different mirror, e.g.:

wget " fonts/final/andale32.exe"

To answer your question, I’m downloading at home. Nothing is blocking anything. I have Ubuntu on two machines. My laptop has Ubuntu 18.04 and I was successful in downloading and installing MS fonts. Went through the same process on my desktop running Ubuntu in VMware virtual. On that machine I ran the update and upgrade and was moved from 18.04 to 18.10. When I download and ran either one of your link suggestions I get “An error occurred while loading achieve”. Is it possible that it has something to do with 18.10?

Your Ubuntu installation is in a virtual machine? In that case, rather than an issue with 18.10, my first guess would be a network misconfiguration in the VM settings.

If you have a bit of time to test various things, you can try to boot a 18.10 LiveCD/USB on your desktop machine and try to install the fonts package from the live session to see if you have the same errors or if it goes fine on a “real” Ubuntu (in the sense that it has direct access to the hardware, especially the network).