After updating Ubuntu Mate (21.04 -> 21.10) the screen stopped working


I've updated Ubuntu Mate to version 21.10 and when I turn on the system, the login panel doesn't display. Instead, I see flashing pixels.

However, I can hear system sounds, and when I enter my password, the screen brightness changes, so the system generally seems to be working.

Please help me with my issue. My laptop model is Lenovo Ideapad 320-15ABR.

For the purposes of anybody else here who wants to debug this issue, this model of laptop contains in-processor AMD Radeon R5 or R7 Graphics, and possibly also an "external" AMD Radeon 530 graphics chip with either 2GB or 4GB of GDDR5 memory.

@Pstrokaty: If you press Ctrl-Alt-F1, do you see a textual login prompt, or do you still see random noise? Answering that question alone will give us a huge clue to the problem.

Thanks for the reply.

When I pressed Ctrl + Alt + F1 I got a black screen with no content.

Without any text? Weird.

OK, I guess that means it's a kernel problem and not an X driver problem or anything.

Just out of curiosity: I know that system updates (and not necessarily system upgrades) leave behind the old kernel, the last kernel that you used and was "known to work", for this exact kind of situation. If you press the Esc key while booting the system up (right after the BIOS/UEFI firmware finishes loading, there should be a message that says to press Esc to interrupt the boot process), this should open up a menu of operating system choices. The default option should be at the top of the list; the default is the kernel with the graphics driver flaw. If you use the down arrow key a few times to navigate to the newest kernel option that is not labelled "Recovery Mode" and is not at the very top of the list, do the graphics work then?

I have a sneaky feeling that the old kernels are purged during a system upgrade (it's been a long time since I did an upgrade myself), but let's just see if the search is fruitful. Sometimes you get unexpected pleasures.

Good luck.

I tried all four options. Only those labelled "recovery mode" worked. Those few Polish words on the screen mean the same thing as "with".

I don't know if it's relevant, but I couldn't change the screen brightness on them because I get the "no external screen" message.

Does anybody else around here have any ideas? I really don't know what I'm doing here now, since I have very little experience with AMD graphics chips and their driver support on Linux -- I'm too cheap to get an external video cards or anything such anymore. Any ideas would be appreciated!

Hi there,

I experienced the same issue on my laptop (HP15-ba049ng) after a clean installation of Ubuntu Mate 21.10 (I ran 20.10 previously). I could see the HP and Ubuntu logos during the startup. I could also hear the login prompt sound but the display remained black.

I connected an external monitor via HDMI, entered my password blindfolded and finally the desktop appeared on the external monitor while the built-in monitor remained grey.

Switching from LightDM to gdm3 fixed the issue for me. I had searched the internet for any possible solutions for quite some time and this pointed me to the right direction: LightDM Black screen on boot - Ask Ubuntu

I still have no idea however why LightDM fails to display anything on the built-in monitor after the login prompt.

I hope that helps