ALT + F2 key combination does not work

desktop
Lenovo

#1

On my Lenovo Thinkpad T460 the key combination Alt + F2 does not work. Does anyone know how to fix it? It should start the Run Application window.


#2

Try to start it in terminal to see if trows any errors . The command is mate-panel --run-dialog
if noy check your keybindings in Control Center/Key Combinations/Desktop section . You should have this


#3

Thanks, the command starts the run-dialog. Strangely, in Control Center > Keyboard Shortcuts I can see Alt + F2, so it should actually have worked out of the box. When trying to assign a new shortcut by pressing Alt + F2 it shows this instead: Alt + XF86AudioLowerVolume. Isn’t this key supposed to be my F2 key? At least it is labeled with both F2 and a volume control symbol.


#4

Wath is your laptop/PC model ? Is your keyboard generic or does it have additional keys ? (Not talking about the FN key combinations) . There must be something wrong in the kbd layout of your installation .


#5

I have a new Lenovo Thinkpad T460. Notebookcheck has recently reviewed it and here is a picture of the actual keyboard layout. Is it a generic keyboard? I am not familiar with this term.


#6

Can you tell me wath does mate settings tell me about the model ?
To check it go to Control Center / Keyboard / Layout and the you should see Keyboard Model .
If it is on Generic keyboard 105 keys then Try to select lenovo and then try other simular thinkpad models . This has happened to me on my previous Laptop . This happens when the system didn’t set proper keyboard layout the first time u installed the system .

EDIT 1

You can test it by binding the run dialog . The right is when you see alt+f2 .


#7

I only see these models when I choose Lenovo from vendors. The default keyboard model according to the Keyboard Preferences is: Generic 105-key (Intl) PC.


#8

Try the t60 one . If it displays Alt + F2 it is the right for you . You can also check all your keys this way :
Righ click layout indicator in the panel and select show current keyboard layout and start pushing the keys . If the button in the app lights up according to the button you clicked it should be OK.


#9

I changed it to IBM ThinkPad R60/T60/R61/T61 model but in the keyboard settings it still says the same thing: Alt + XF86AudioLowerVolume. Maybe this is just a terminology issue? In both cases (with the generic keyboard and the other option you suggested) I can press Alt + F2 and it launches the Run Application window but only after I have manually set it to Alt + XF86AudioLowerVolume.

It seems there is no option for me to set it back to its default generic keyboard? I don’t notice any difference between this and the generic model. Clicking the Reset to Default button still keeps the IBM ThinkPad R60/T60/R61/T61 model activated instead of going back to Generic 105-key (Intl) PC.

With both options, most of the F-keys don’t work. Do you know if there are any keyboard configuration files that I can import to update the available models in the keyboard settings? It certainly would be great if they other keys are working as intended to.


#10

Try to bind it with ALT+FN+F2 and if it binds to ALT+F2 , I am a complete ■■■■■■ . There should be a option in BIOS witch lets you switch fn emulation mode . Some laptops have a function to use the hotkeys withought fn emulation . That reverts the FN so you have to press FN+F2 to actualy use F2 and just F2 to acces the multimedia or extra keys . The XF86 refers to those media keys .


#11

This is it! Thanks so much. I have to press Fn + Alt + F2 to start the Run Application box and this also displays it correctly as Alt + F2 in the Keyboard Shortcuts.

This is exactly the case with my T460. I guess it works well now, but I wonder how to reset the keyboard model to the default Generic 105-key (Intl) PC in the Keyboard Preferences. When I click on the Reset to defaults button, nothing happens and it still shows the previous keyboard model setting:


#12

As the manufacturor choose generic and there you will find it . The reset buttons resets the layouts not the model .


#13

Thanks a lot, all is working well now.