AMD proprietary fglrx driver broken - open source driver works OK

Warning for users to stay with the default open source driver for AMD/ATI Catalyst/Radeon chipset for now. Do not use fglrx proprietary driver. Discovered this installing on an AMD based Acer Aspire Notebook. When installing proprietary driver it will hang on boot, and recovery will be almost impossible for the average user. You can read more about it here:

Other than that, really liking ubuntuMATE 15.10, congrats and thanks for a great new release!


I am using the AMD/ATI driver with updates for my Radeon R7 200 series GPU on an Asus rig with Intel i3 processor. So far, it’s working very well.

Yep, the Ubuntu Wily Werewolf Release Notes warns about this too.

AMD’s fglrx driver does not work with the current kernel (1493888). It is warmly recommended to uninstall the fglrx driver before upgrading to Ubuntu 15.10. The open source “radeon” driver can be used as a temporary replacement until a fix is available.

That happened to me when I was on 15.04 on my acer laptop. It was a plan to fix. Can’t remember how I fixed it but I did a lot of searching online with out having to do a fresh install.

I am currently using 14.04 LTS 64 Bit. Could that be why my proprietary ATI/AMD driver is working fine?

Appears there is a fix in the works, involves fooling the fglxr installer into thinking you have gcc 4.9 instaed of gcc 5. I would assume this worked before 15.10. I use 14.04 LTS on my desktop with an Nvidia 304 tested driver and am really happy with that as my #1 machine. The AMD/ATI fglrx issue was a clean 15.10 install on a Acer Notebook that I gave up on Windows 7/Windows 10 upgrade. The open source driver does appear to be working okay for now though.

I have this same problem, running 15.10 and I have tried to downgrade to the open source drivers but I’m not getting any display now. I can login via ssh so I don’t want to have to rebuild the box to fix this. Can someone point me at a place that I could get help troubleshooting why I have no display at all now.

I followed these directions to downgrade:

Solved the problem
It looks like lightdm wasn’t reloading properly after I uninstalled the proprietary drivers so once I completed a reinstall of lightdm the monitor started working again.

Thanks for all the info on the proprietary drivers and the ongoing issues.



1 Like

Glad you got it going again @snugglej. Reading the last couple entries in bug report I may wait it out a bit.

Yeah it wasn’t fun and you have glitches in caja to deal with if you aren’t using the proprietary driver. I would just wait till AMD releases a supported driver. Also you can’t run Steam or 3d accelerated software if you aren’t running the proprietary driver.

Thank you misterA for sharing this information with all.
Let’s hope that AMD releases a compatible driver

I’ve gone back to 14.04 LTS. All is well… :grinning: