Android and Ubuntu Mate issue

When it is android recovery mode,connected to laptop(Lenovo B50-45),how to transfer ROM and GAPPS zip file to sdcar(external).MTP and ADB working i am novice in linux world,therefore i need help with terminal commands.As long as I am used windows,that be easy with typing adb devices then adb push xxxxxx(name ROM) /sdcard/. and hit enter.With push and pull comands,resolve that.But in the Linux these terminal comands,typing different.For example ./adb push or ./adb-linux-push…I tried all day to find solution on google,but i I failed :confounded: please if someone knows,to help.That again I can get it,my Samsung Galaxy S3.

Prefix the commands with sudo

Ok @Wimpy i traed today,and wrote here suksided or not.Tnx for helping me :slight_smile:

When setting up adb for the first time, you need to setup the “udev” rules. Like this:

Especially if you are not using the adb from the official repos. I think, that if you are using the official repos, the udev rules may be setup for you. If you are using “./adb” then you are probably not using the ones from the official repos. To install that, I believe you can:

sudo apt-get install adb

If those do not work then please post us the output of adb devices, while your device is connected and with adb enabled in the “Developer Options” on your device.


@Meticulus already I have a,mtp and adb enabled in ubuntu…and enabled developers mode.Has changed and rooted so far,at least about 30 android devices.I also find solution for this,TWRP is advanced recovery with built-in file manager.So if by accident some wipe(delete) current android OS in recovery,without backup must have worked adb.Boot device in recovery connect with PC, then type adb push xxxxx(file name,with extension) /sdcard/. and hit enter.Then it will transfered ROM and GAPPS on INTERNAL sdcard,after that in recovery go to Advanced tab-File Manager and simply move them from internal to external sdcar…flas it and gota fuly worked device.That is solution for Samsung Galaxy S3,but I think that be work for other Samsung devices.Yesterday i fix my device,if
some got the same problem this is solution :wink:

I ran into this issue the other week, having not been aware of udev rules (thanks @Meticulus), I get around this another way – start the adb server as root:

sudo adb start-server

Then any commands like adb push work fine as the regular user. adb devices will show the device as having permission.

1 Like

This is a link to setup mtp and udev rules,and this ia a link to setup adb in ubuntu 16.04.This the second link is writen to setup adb and QtADB,but QtADB
abandoned project only instrukcions for adb works…

I think the only small disadvantage with running the adb server as root is that; if you use ‘adb pull’, the pulled file or files might be created with ‘root’ permissions. There may be other, quirky things of that nature but I can’t think of any others. :wink:

Here is Google’s Android Developer page on the subject:

Apparently the package is:

sudo apt-get install android-tools-adb

And the page notes that: “This gives you a community-maintained default set of udev rules for all Android devices.

1 Like